Cutting Sticks(区间dp)

You have to cut a wood stick into pieces. The most affordable company, The Analog Cutting Machinery,
Inc. (ACM), charges money according to the length of the stick being cut. Their procedure of work
requires that they only make one cut at a time.
It is easy to notice that different selections in the order of cutting can led to different prices. For
example, consider a stick of length 10 meters that has to be cut at 2, 4 and 7 meters from one end.
There are several choices. One can be cutting first at 2, then at 4, then at 7. This leads to a price
of 10 + 8 + 6 = 24 because the first stick was of 10 meters, the resulting of 8 and the last one of 6.
Another choice could be cutting at 4, then at 2, then at 7. This would lead to a price of 10 + 4 + 6 =
20, which is a better price.
Your boss trusts your computer abilities to find out the minimum cost for cutting a given stick.
Input
The input will consist of several input cases. The first line of each test case will contain a positive
number l that represents the length of the stick to be cut. You can assume l < 1000. The next line will
contain the number n (n < 50) of cuts to be made.
The next line consists of n positive numbers ci (0 < ci < l) representing the places where the cuts
have to be done, given in strictly increasing order.
An input case with l = 0 will represent the end of the input.
Output
You have to print the cost of the optimal solution of the cutting problem, that is the minimum cost of
cutting the given stick. Format the output as shown below.
Sample Input
100
3
25 50 75
10
4
4 5 7 8
0
Sample Output
The minimum cutting is 200.
The minimum cutting is 22.

题意:给定一个长度为l的木棍,接下来给一些切割点,每次切割的花费是木棍的长度,求完成所有切割所需要的最小花费。

思路:二维dp,dp[i][j]表示切割区间 i - j 所需要的最小花费,那么可以得出递推式:dp[i][j]=min(dp[i][j], dp[i][k] + dp[k][j] + a[j] - a[i]) 其中,i<k<j
里面的a数组存储的是切割点的位置

这道题有两种做法(思路和递推式都是一样的)



做法1:记忆化搜索

#include<iostream>
#include<cstring>
using namespace std;
#define N 1005
#define inf 0x3f3f3f3f
int dp[N][N];
int a[N];
int dfs(int l,int r)
{
	if(dp[l][r]>=0)  //若此状态已经搜过
		return dp[l][r];
	if(l>=r-1)    //必须把l和r相邻的情况也特判了,否则会返回最大值
		return dp[l][r]=0;
	dp[l][r]=inf;
	for(int k=l+1;k<r;k++)
		dp[l][r]=min(dp[l][r],dfs(l,k)+dfs(k,r)+a[r]-a[l]);
	return dp[l][r];
}
int main()
{
	int l,n;
	while(~scanf("%d",&l) && l)
	{
		memset(a,0,sizeof(a));
		memset(dp,-1,sizeof(dp));
		cin>>n;
		for(int i=1;i<=n;i++)
			scanf("%d",&a[i]);
		a[0]=0;a[n+1]=l;
		printf("The minimum cutting is %d.\n",dfs(0,n+1));
	}
	return 0;
}


做法2:非递归

#include<iostream>
#include<cstring>
using namespace std;
#define N 1005
#define inf 0x3f3f3f3f
int dp[N][N];
int a[N];
int main()
{
	int l,n;
	while(~scanf("%d",&l) && l)
	{
		cin>>n;
		memset(a,0,sizeof(a));
		memset(dp,0,sizeof(dp));  //注意初始化的值
		for(int i=1;i<=n;i++)
			scanf("%d",&a[i]);
		a[n+1]=l;
		for(int len=1;len<=n+1;len++)  //枚举区间长度
			for(int i=0;i+len<=n+1;i++)  //注意右边不能越界
			{
				int j=i+len;
				for(int k=i+1;k<j;k++)
				{
					if(dp[i][j]==0)   //如果为初值,直接赋值
						dp[i][j]=dp[i][k]+dp[k][j]+a[j]-a[i];
					else
						dp[i][j]=min(dp[i][j],dp[i][k]+dp[k][j]+a[j]-a[i]);
				}
			}
		printf("The minimum cutting is %d.\n",dp[0][n+1]);
	}
	return 0;
}
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值