1155 Heap Paths (30分)-Heap、数组

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

One thing for sure is that all the keys along any path from the root to a leaf in a max/min heap must be in non-increasing/non-decreasing order.

Your job is to check every path in a given complete binary tree, in order to tell if it is a heap or not.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (1<N≤1,000), the number of keys in the tree. Then the next line contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, first print all the paths from the root to the leaves. Each path occupies a line, with all the numbers separated by a space, and no extra space at the beginning or the end of the line. The paths must be printed in the following order: for each node in the tree, all the paths in its right subtree must be printed before those in its left subtree.

Finally print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all.

Sample Input 1:

8
98 72 86 60 65 12 23 50

Sample Output 1:

98 86 23
98 86 12
98 72 65
98 72 60 50
Max Heap

Sample Input 2:

8
8 38 25 58 52 82 70 60

Sample Output 2:

8 25 70
8 25 82
8 38 52
8 38 58 60
Min Heap

Sample Input 3:

8
10 28 15 12 34 9 8 56

Sample Output 3:

10 15 8
10 15 9
10 28 34
10 28 12 56
Not Heap

解题思路:

  1. 由于堆是完全二叉树,并且输入为层次序列,所以采用数组来表示二叉树,数组元素储存父结点序号;
  2. 为了输出根到每一个叶结点的路径,需要递归输出叶结点到根的路径;
  3. 为了从右到左输出路径,需要判断倒数第二层有多少个叶结点。由于是完全二叉树,第n层最右结点编号为2^{n}-1。对于结点数为N的二叉树,首先要找到一个最小m,使其满足2^{m}-1\geq N,那么倒数第二次叶结点数量为\left ( 2^{m} -1-N\right )/2,最右边叶结点序号为2^{m-1}-1,将倒数第二次叶结点输出完毕,然后输出最后一层叶结点,个数为N-2^{m-1}+1,起点为N。

AC代码:

#include <iostream>
#include <cmath>
using namespace std;
#define Max 1001
#define Inf 1E6+1
int heap[Max],IsCertain=0,flag=0,sign;
void printpath(int i);
int main(){
	int i,j,N,num;
	heap[0]=Inf;
	cin>>N;
	for(i=1;i<=N;i++){
		scanf("%d",&heap[i]);
	}
	for(num=2;num<N+1;num*=2);
	for(i=0,j=num/2-1;i<(num-1-N)/2;i++,j--){
		printpath(j);
		printf("\n");	
	}
	
	for(i=N;i>num/2-1;i--){
		printpath(i);
		printf("\n");	
	}
	if(flag)
		printf("Not Heap\n");
	else{
		if(sign)
			printf("Max Heap\n");
		else
			printf("Min Heap\n");
	}
	return 0;
	
}
void printpath(int i){
	if(i==1)
		printf("%d",heap[i]);
	else{
		printpath(i/2);
		printf(" %d",heap[i]);
		if(!flag){
			if(heap[i]!=heap[i/2]){
				if(IsCertain){
					if(heap[i]>heap[i/2]&&sign)
						flag=1;
					else if(heap[i]<heap[i/2]&&!sign)
						flag=1;
				}
				else{
					IsCertain=1;
					sign=heap[i]<heap[i/2];
				}
	  		}
		}
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值