PAT甲级1155 Heap Paths (30 分)

11 篇文章 1 订阅
10 篇文章 0 订阅

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

One thing for sure is that all the keys along any path from the root to a leaf in a max/min heap must be in non-increasing/non-decreasing order.

Your job is to check every path in a given complete binary tree, in order to tell if it is a heap or not.
Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (1<N≤1,000), the number of keys in the tree. Then the next line contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.
Output Specification:

For each given tree, first print all the paths from the root to the leaves. Each path occupies a line, with all the numbers separated by a space, and no extra space at the beginning or the end of the line. The paths must be printed in the following order: for each node in the tree, all the paths in its right subtree must be printed before those in its left subtree.

Finally print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all.
Sample Input 1:

8
98 72 86 60 65 12 23 50

Sample Output 1:

98 86 23
98 86 12
98 72 65
98 72 60 50
Max Heap

Sample Input 2:

8
8 38 25 58 52 82 70 60

Sample Output 2:

8 25 70
8 25 82
8 38 52
8 38 58 60
Min Heap

Sample Input 3:

8
10 28 15 12 34 9 8 56

Sample Output 3:

10 15 8
10 15 9
10 28 34
10 28 12 56
Not Heap

题意:给出一个完全二叉树(完全二叉树:刨去最后一层以外,每一层都是满的,或者说去掉最后一层之后的树是一棵满二叉树)。现在问你这样一棵完全二叉树是不是一个堆,大根堆还是小根堆。首先输出遍历序列,从根节点输出到叶子节点。最后输出是不是堆,大根堆还是小根堆。
思路:题目给出的是层次遍历,真的是太好了,直接数组存储,如果根节点的编号是i,则左子树的根节点编号为i2,右子树的根节点编号为i2+1.所以直接遍历,输出,就完了。对于是不是大根堆,小根堆,直接判断输出节点是不是比父节点大或者小就好了。
上代码(看你们写了那么多。。)

#include<bits/stdc++.h>
#pragma GCC optimize(2)
#define MAXN 1010
#define maxnode 1000005
#define sigma_size 26
#define md 12345678
#define INF 0x3f3f3f3f
using namespace std;

int n;
int level[MAXN],path[MAXN];
bool Minn,Maxn;

void dfs(int u,int deep)
{
    path[deep]=level[u];
    if(u*2+1<=n)
        dfs(u*2+1,deep+1);
    if(u*2<=n)
        dfs(u*2,deep+1);
    if(u*2+1>n&&u*2>n)
    {
        for(int i=1;i<=deep;i++)
        {
            printf("%d%c",path[i],i==deep?'\n':' ');
            if(i!=1)
            {
                if(path[i]>path[i-1])
                    Minn=true;
                if(path[i]<path[i-1])
                    Maxn=true;
            }
        }
    }
    return ;
}

int main()
{
    scanf("%d",&n);
    for(int i=1;i<=n;i++)
    {
        scanf("%d",&level[i]);
    }
    Minn=Maxn=false;
    dfs(1,1);
    if(Minn&&Maxn)
    {
        printf("Not Heap\n");
    }
    else
    {
        if(Minn)
            printf("Min Heap\n");
        else
            printf("Max Heap\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值