PAT_(树的遍历)1079 Total Sales of Supply Chain (25分) 1090 Highest Price in Supply Chain (25分)

目录

1079 Total Sales of Supply Chain (25分)

1090 Highest Price in Supply Chain (25分)


 

1079 Total Sales of Supply Chain (25分)

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P 

and sell or distribute them in a price that is r% higher than P.

Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier(树根节点), and there is no supply cycle.

Now given a supply chain, you are supposed to tell the total sales from all the retailers

Input Specification:

Each input file contains one test case. For each case, the first line contains three positive numbers: N (≤10^​5​​), the total number of the members in the supply chain (and hence their ID's are numbered from 0 to N−1, and the root supplier's ID is 0);  P, the unit price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

K​i​​ ID[1] ID[2] ... ID[K​i​​]

where in the i-th line,

 K​i​​ is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID's of these distributors or retailers. 

K​j​​ being 0 means that the j-th member is a retailer, then instead the total amount of the product will be given after K​j​​. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the total sales we can expect from all the retailers, accurate up to 1 decimal place. It is guaranteed that the number will not exceed 10​^10​​.

Sample Input:

10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0 7
2 6 1
1 8
0 9
0 4
0 3

Sample Output:

42.4

题目大意:叶子节点是retailer,root节点是supplier,中间节点是distributors,只有零售商直接与customer交易,从root到retailer的路径上,每经过一个节点就抬高价钱的r%,product的初始价格是p元,求总的sale;

 

例:sale1.80*((7+9)*(1+0.01)^2+(4+3)*(1+0.01)^3)=42.4    思路:dfs 

注意:c++  cmath  pow(double,int),我之前在dfs传参中rate*(1+r) 但是有精度问题,

 

#include<cstdio>
#include<cstdlib>
#include<algorithm>
#include<iostream>
#include<string>
#include<cstring>
#include<vector>
#include<map>
#include<cmath>
#define pb push_back 
using namespace std;
const int maxn=100005;
double sum;
int n; 
double p,r;
vector<vector<int>> graph;
map<int,int> mp;
int vis[maxn];

void dfs(int num,int depth){//double rate
	if(!graph[num].size()){	
		sum+=mp[num]*pow(1+r,depth);   //printf("rate=%.3f ",rate);
		return ;
	} 
	int len=graph[num].size();	
	for(int i=0;i<len;i++){
		int node=graph[num][i];
		if(!vis[node]) {
			vis[node]=1;
			dfs(node,depth+1); //rate*(1+r)
		}
	}
}
int main(){
	scanf("%d%lf%lf",&n,&p,&r);
	r/=100;
	int num,tmp;
	for(int i=0;i<n;i++){
		graph.pb(vector<int>());              
		scanf("%d",&num);
		if(num==0){
			//retailer
			scanf("%d",&tmp);
			mp[i]=tmp;
		}else{
			while(num--){
				scanf("%d",&tmp);
				graph[i].pb(tmp);
			}
		}		
	}
	vis[0]=1;
	dfs(0,0);
	sum=p*sum;
	printf("%.1f\n",sum);
	
	
	return 0;		
}

 

1090 Highest Price in Supply Chain (25分)

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.(同上)

Now given a supply chain, you are supposed to tell the highest price we can expect from some retailers.

Input Specification:

Each input file contains one test case. For each case, The first line contains three positive numbers: N (≤10^​5​​), the total number of the members in the supply chain (and hence they are numbered from 0 to N−1); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then the next line contains N numbers, each number S​i​​ is the index of the supplier for the i-th member. S​root​​ for the root supplier is defined to be −1. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the highest price we can expect from some retailers, accurate up to 2 decimal places, and the number of retailers that sell at the highest price. There must be one space between the two numbers. It is guaranteed that the price will not exceed 10​^10​​.

Sample Input:

9 1.80 1.00
1 5 4 4 -1 4 5 3 6

Sample Output:

1.85 2

题目大意:首先n,p,r;跟上题中的一样,Si数组含义是 [Si,index]的一条供应边,例:1->0 5->1 ... Si=-1代表此节点是树的root;

然后就是建树,找deepest 节点;(同时记录deepest的节点的个数)dfs 

#include<cstdio>
#include<cstdlib>
#include<algorithm>
#include<iostream>
#include<string>
#include<cstring>
#include<vector>
#include<map>
#include<cmath>
#define pb push_back 
using namespace std;
const int maxn=100005;
double sum;
int n; 
double p,r;
vector<int> graph [maxn];
int deepest=-1; 
int vis[maxn];
int cnt;
void dfs(int num,int depth){
	if(!graph[num].size()){	
		if(depth>deepest) {
			deepest=depth; cnt=1;
		}else if(deepest==depth){
			cnt++;
		}
		return ;
	} 
	int len=graph[num].size();	
	for(int i=0;i<len;i++){
		int node=graph[num][i];
		if(!vis[node]) {
			vis[node]=1;
			dfs(node,depth+1); 
		}
	}
}
int main(){
	scanf("%d%lf%lf",&n,&p,&r);
	r/=100.0;
	//graph=vector<int>[n];
	int tmp,root;
	for(int i=0;i<n;i++){
		scanf("%d",&tmp);
		if(tmp!=-1){
			graph[tmp].pb(i);
		}else{
			root=i;
		}		
	}
	vis[root]=1;
	dfs(root,0);
	sum=p*pow(1+r,deepest);	
	printf("%.2f %d\n",sum,cnt);//printf("%d\n",deepest);
	return 0;		
}

 

 

 

 

说实话一开始没看懂这个图是怎么构建的,但是明白了怎么建图之后就很简单了!

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值