poj2349:Arctic Network(最小生成树模板)

描述:

The Department of National Defence (DND) wishes to connect several northern outposts by a wireless network. Two different communication technologies are to be used in establishing the network: every outpost will have a radio transceiver and some outposts will
 in addition have a satellite channel. 
Any two outposts with a satellite channel can communicate via the satellite, regardless of their location. Otherwise, two outposts can communicate by radio only if the distance between them does not exceed D, which depends of the power of the transceivers.
 Higher power yields higher D but costs more. Due to purchasing and maintenance considerations, the transceivers at the outposts must be identical; that is, the value of D is the same for every pair of outposts. 
Your job is to determine the minimum D required for the transceivers. There must be at least one communication path (direct or indirect) between every pair of outposts.

输入:

The first line of input contains N, the number of test cases. The first line of each test case contains 1 <= S <= 100, the number of satellite channels, and S < P <= 500, the number of outposts. P lines follow, giving the (x,y) coordinates of each outpost in
 km (coordinates are integers between 0 and 10,000).
输出:

For each case, output should consist of a single line giving the minimum D required to connect the network. Output should be specified to 2 decimal points.

Sample Input

1
2 4
0 100
0 300
0 600
150 750

Sample Output

212.13

题意:给你P个点,其中有S个是无线电卫星,两个无线电卫星的连接距离可以是无限大可以是,要求任意两点之间都必须相连,有公式则一共有(n*(n-1))/2条有向边,而题意只要求这个图是连通图即可,所以N个点,只需要N-1条边。对于样例而言:我们把所有边的长度算出来,升序排列,输出N-2条边的值即可,因为保证花费最小,而且要连通。

样例测试边权值图片:

箭头所指就是我们求得答案

代码:

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
#include<iostream>
using namespace std;
struct node
{
    int start;
    int end;
    double cost;
} t[1001000];
int cmp(node a,node b)
{
    return a.cost <b.cost ;
}
int per[1100];
int find(int x)
{
    int r=x;
    while(r!=per[r])	r=per[r];
    return r;
}
int join(int x,int y)
{
    int fx=find(x);
    int fy=find(y);
    if(fx!=fy)
    {
        per[fx]=fy;
        return 1;
    }
    return 0;
}
int main()
{
    int k,m,n,p,i,j;
    int x[110010],y[110010];
    scanf("%d",&p);
    while(p--)
    {
        for(i=0; i<1100; i++)
                    per[i]=i;
        scanf("%d%d",&m,&n);
        for(i=1; i<=n; i++)
        	scanf("%d%d",&x[i],&y[i]);
        k=0;
        for(i=1; i<=n; i++)		for(j=i+1; j<=n; j++)
            {
                t[k].start=i;
                t[k].end =j;
                t[k].cost =sqrt(1.0*(x[i]-x[j])*(x[i]-x[j])+1.0*(y[i]-y[j])*(y[i]-y[j]));
                k++;
            }
        sort(t,t+k,cmp);
        int v=0;
        double ans;
        for(i=0; i<k; i++)
        {
            if(join(t[i].start,t[i].end))			v++;
            if(v==n-m)
            {
                ans=t[i].cost;
                break;
            }
        }
        printf("%.2f\n",ans);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值