Trailing Zeroes

You task is to find minimal natural number N, so that N! contains exactly Q zeroes on the trail in decimal notation.

As you know N! = 1*2*...*N. For example, 5! = 120, 120 contains one zero on the trail.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case contains an integer Q (1 ≤ Q ≤ 108) in a line.

Output

For each case, print the case number and N. If no solution is found then print 'impossible'.

Sample Input

3

1

2

5

Sample Output

Case 1: 5

Case 2: 10

Case 3: impossible

题意:求满足情况的阶乘末尾0的个数。

解题思路:5的个数即使0的个数;统级一个数有多少个5构成。///利用二分查找到最小的值

#include<iostream>
#include<algorithm>
using namespace std;

int solve(int n)  //统计0的个数
{
    int sum=0;
    while(n)
    {
        sum+=n/5;
        n=n/5;
    }
    return sum;
}
int er(int n)
{
    int l=0,r=500000000;
    while(l<=r)
    {
        int mid=(l+r)>>1;
        if(solve(mid)<n)
            l=mid+1;
        else
            r=mid-1;
    }
    if(solve(l)==n)
        return l;
    return 0;
}
int main()
{
    int t,k=0;
    cin>>t;
    while(t--)
    {
        int n;
        cin>>n;
        if(!er(n))
            cout<<"Case "<<++k<<": impossible"<<endl;
        else
            cout<<"Case "<<++k<<": "<<er(n)<<endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值