PTA 1103 Integer Factorization java与c++实现

1103 Integer Factorization (30 分)
The K−P factorization of a positive integer N is to write N as the sum of the P-th power of K positive integers. You are supposed to write a program to find the K−P factorization of N for any positive integers N, K and P.

Input Specification:

Each input file contains one test case which gives in a line the three positive integers N (≤400), K (≤N) and P (1<P≤7). The numbers in a line are separated by a space.

Output Specification:

For each case, if the solution exists, output in the format:

N = n[1]^P + … n[K]^P
where n[i] (i = 1, …, K) is the i-th factor. All the factors must be printed in non-increasing order.

Note: the solution may not be unique. For example, the 5-2 factorization of 169 has 9 solutions, such as
​​ , or more. You must output the one with the maximum sum of the factors. If there is a tie, the largest factor sequence must be chosen – sequence

If there is no solution, simple output Impossible.

Sample Input 1:

169 5 2
Sample Output 1:

169 = 6^2 + 6^2 + 6^2 + 6^2 + 5^2
Sample Input 2:

169 167 3
Sample Output 2:

Impossible

JAVA:

import java.util.*;

public class Main {
	static int ns,k,p;
	static List<Integer> list = new ArrayList<>();
	static List<Integer> finalList = new ArrayList<>();
	static boolean flag = false;
	
	public static void main(String[] args) throws Exception {
		Scanner in = new Scanner(System.in);
		ns = in.nextInt();
		k = in.nextInt();
		p = in.nextInt();
		for(int i=1;i<=20;i++){
			dfs(ns,i,p,0);
		}
		if(finalList.size()<k){
			System.out.print("Impossible");
		}else{
			System.out.print(ns + " = ");
			for(int i=0;i<k;i++){
				System.out.print(finalList.get(k-1-i) + "^" + p);
				if(i!=k-1){
					System.out.print(" + ");
				}
			}
		}
	}
	
	static void dfs(int n,int num,int pow,int count){
		int sum = 1;
		for(int i=0;i<pow;i++){
			sum*=num;
		}
		n = n-sum;
		count += 1;
		if(n<0) {
			flag = true;
			return;
		}
		if(n==0 && count<k) {
			flag = true;
			return;
		}
		if(n>0 && count == k) {
			return;
		}
		if(n == 0 && count == k){
			list.add(num);
			finalList.clear();
			finalList.addAll(list);
			list.remove(list.size()-1);
			flag = true;
			return;
		}
		list.add(num);
		for(int i=num;i<20;i++){
			dfs(n,i,pow,count);
			if(flag == true){
				flag = false;
				break;
			}
		}
		list.remove(list.size()-1);
	}
}

提交后测试点5超时,而其他测试点都是正常时间100+ms。想办法各种优化之后还是超时,于是把代码转为c++,运行通过。

c++:

#include <iostream>
#include<vector>
using namespace std;

int ns,k,p;
vector<int> list;
vector<int> finalList;
bool flag = false;
void dfs(int n,int num,int pow,int count);

int main(int argc, char** argv) {
	cin>>ns>>k>>p;
	for(int i=1;i<=20;i++){
        dfs(ns,i,p,0);
    }
    if(finalList.size()<k){
        cout<<"Impossible";
    }else{
        cout<<ns<<" = ";
        for(int i=0;i<k;i++){
            cout<<finalList[k-1-i]<<"^"<<p;
            if(i!=k-1){
                cout<<" + ";
            }
        }
    }
	return 0;
}

void dfs(int n,int num,int pow,int count){
	int sum = 1;
	for(int i=0;i<pow;i++){
		sum*=num;
	}
	n = n-sum;
	count += 1;
	if(n<0) {
		flag = true;
		return;
	}
	if(n==0 && count<k) {
		flag = true;
		return;
	}
	if(n>0 && count == k) {
		return;
	}
	if(n == 0 && count == k){
        list.push_back(num);
		finalList.clear();
        finalList.assign(list.begin(),list.end());
		list.pop_back();
		flag = true;
		return;
	}
	list.push_back(num);
	for(int i=num;i<20;i++){
		dfs(n,i,pow,count);
		if(flag == true){
			flag = false;
			break;
		}
	}
	list.pop_back();
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值