1103. Integer Factorization (30)

389 篇文章 1 订阅
140 篇文章 0 订阅

1103. Integer Factorization (30)
时间限制 1200 ms 内存限制 65536 kB 代码长度限制 16000 B
判题程序 Standard 作者 CHEN, Yue

The K-P factorization of a positive integer N is to write N as the sum of the P-th power of K positive integers. You are supposed to write a program to find the K-P factorization of N for any positive integers N, K and P.
Input Specification:
Each input file contains one test case which gives in a line the three positive integers N (<=400), K (<=N) and P(P> && P<=7). The numbers in a line are separated by a space.
Output Specification:
For each case, if the solution exists, output in the format:
N = n1^P + … nK^P
where ni (i=1, … K) is the i-th factor. All the factors must be printed in non-increasing order.
Note: the solution may not be unique. For example, the 5-2 factorization of 169 has 9 solutions, such as 122 + 42 + 22 + 22 + 12, or 112 + 62 + 22 + 22 + 22, or more. You must output the one with the maximum sum of the factors. If there is a tie, the largest factor sequence must be chosen – sequence { a1, a2, … aK } is said to be larger than { b1, b2, … bK } if there exists 1<=L<=K such that ai=bi for ibL
If there is no solution, simple output “Impossible”.
Sample Input 1:
169 5 2
Sample Output 1:
169 = 6^2 + 6^2 + 6^2 + 6^2 + 5^2
Sample Input 2:
169 167 3
Sample Output 2:
Impossible

#include <algorithm>
#include <functional>
#include <iostream>
#include <queue>
#include <cmath>

using namespace std;
const int MaxN = 410;
int Fac[MaxN];
int res[MaxN],resN;
int n = 0,MaxSum = -1,backSum=-1;
int Power[MaxN];

bool solution = false;


void Memcpy(int n)
{
    for (int i = 0; i < n; ++i)
        res[i] = Fac[i];
}

bool Memcmp(int n)
{
    for (int i = 0; i < n; ++i)
    {
        if (res[i] != Fac[i])
            return res[i] < Fac[i];
    }
    return false;
}

void DFS(int Num, int sum, int next,int K,int now,int p,int FacSum)
{
    if (sum > Num || next <= 0 || now > K)
        return;
    else if (sum == Num)
    {
        if (now == K)
        {
            if (FacSum >  backSum || (FacSum == backSum && Memcmp(n)))
            {
                Memcpy(n);
                resN = n;
                backSum = FacSum;
            }
            solution = true;
        }
        else
            return;
    }
    else
    {
        for (int i = next; i > 0; --i)
        {
            Fac[n++] = i;
            DFS(Num, sum + Power[i], i, K, now + 1, p, FacSum + i);
            --n;
        }
    }
}

void Init(int n,int P)
{
    for (int i = 1; i <= n; ++i)
        Power[i] = pow(i, P);
}

int main()
{
#ifdef _DEBUG
    freopen("data.txt", "r+", stdin);
#endif

    //std::ios::sync_with_stdio(false);

    int Num, N, P;
    cin >> Num >> N >> P;

    int now = (int)pow(Num, 1.0 / P);

    Init(now, P);

    DFS(Num, 0, now, N, 0, P,0);

    if (!solution)
        printf("Impossible");
    else
    {
        printf("%d = ", Num);
        for (int i = 0; i < resN; ++i)
        {
            printf("%d^%d", res[i], P);
            if (i != resN - 1)
                printf(" + ");
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值