【C++_OJ_指针】数组最大值(指针参数)

题目描述

写函数void search(int *num,int n,int *nmax,int *nmaxindex)实现在含n各元素的数组num中查找最大值及其第一次出现下标,分别通过指针nmax,nmaxindex返回。

写函数void input(int *num,int n),输入数组num的n个数。

主函数输入数据,调用input, search, 输出最大值及其第一次出现下标。

不可以在主函数中计算。

输入

测试次数t

每组测试数据一行: 数据个数n(n>1) n个整数

输出

每组测试数据输出一行:

数组最大值 数组最大值第一次出现下标(下标从0开始)

输入样例1

2
10 1 2 3 4 5 6 7 8 9 -10
20 9 10 20 40 50 999999 -99 999998 0 9 20 11 12 432 53 3421 6 42 43 34

输出样例1

9 8
999999 5

#include<iostream>
#include<iomanip>
using namespace std;

void search(int *num,int n,int *nmax,int *nmaxindex)
{
    *nmax =0;
    *nmaxindex = 0;

    for(int i=0;i<n;i++)
    {
        if(num[i] > *nmax)
        {
            *nmax = num[i];
            *nmaxindex = i;
        }
    }
}

void input(int *num,int n)
{
    for(int i=0;i<n;i++)
        cin >> num[i];
}

int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        int n,nmax,nmaxindex;
        cin >> n;
        int *p = new int[n];
        
        input(p,n);
        search(p,n,&nmax,&nmaxindex);

        cout<<nmax<<" "<<nmaxindex<<endl;

        delete []p;
    }

    return 0;
}
  • 2
    点赞
  • 11
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Ferry_xie

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值