PAT甲级1046答案(使用C语言)

题目描述

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3,105​​ ]), followed by N integer distances D​1​​ D​2​​ ⋯ D​N​​ , where D​i​​ is the distance between the i-th and the (i+1)-st exits,and D​N​​ is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤10​4​​ ), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107​​ .

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output:

3
10
7

题目要求描述:

题目给出一个圈,圈上有n个点,每个点之间存在路径和距离,给出两个点,并求出这两点间的最短距离并输出。

编写时注意当结束点为1时的情况

AC代码

#include<stdio.h>
#include<stdlib.h>
#include<algorithm>
using namespace std;

int n, dis[100000], l_num, shortest[10000];

int get_dis(int start, int end){
	int a = 0;
	if(start < end){
		for(start; start <= end; start++){
				a += dis[start];
			}
		}	
	else{
		for(end; end >= start; end--){
			a += dis[end];
		}
	}
	return a;
}

int main(){
	scanf("%d", &n);
	int total_dis = 0;
	for(int i = 0; i < n; i++){
		scanf("%d", &dis[i]);
		total_dis += dis[i];
	}
	//printf("total_dis:%d\n", total_dis);
	scanf("%d", &l_num);
	int start, end;
	for(int j = 0; j < l_num; j++){
		scanf("%d%d", &start, &end);
		start -= 1;
		if(end == 1) end = n - 1;
		else end -= 2;
		//printf("start:%d,end:%d\n", start,end);
		int dis1 = get_dis(start, end);
		//printf("dis1:%d", dis1);
		int dis2 = total_dis - dis1;
		//printf("dis2:%d\n", dis2);
		if(dis1 < dis2) shortest[j] = dis1;
		else shortest[j] = dis2;
	}

	for(int k =0 ; k < l_num; k++){
		printf("%d\n", shortest[k]);
	}
	return 0;

}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值