PAT甲级1046 Shortest Distance (20 分)

题目详情 - 1046 Shortest Distance (20 分) (pintia.cn)

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3,105]), followed by N integer distances D1​ D2​ ⋯ DN​, where Di​ is the distance between the i-th and the (i+1)-st exits, and DN​ is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output:

3
10
7

题意

给定N各形成圆圈的出口,每两个出口之间的距离不同,求指定两出口之间的最短距离,每个出口只能能到达与它临近的两个出口。

思路

形成圆圈,任意两个出口有两个方向可以到达,则用sum保存走完整个圆圈的距离;

使用dist[i]保存从1_th出口到i_th出口之间距离,则从st_th到达en_th的距离则为temp = dist[en-1]-dist[st-1](假设st小于en);

另一条的距离位sum-temp;

最短路径:min(temp,sum-temp);

注意点

  1. st 与 en 的大小;

代码:

#include<bits/stdc++.h>
using namespace std;
int main()
{
    int N = 0, x = 0, sum = 0, cnt = 0;
    cin >> N;
    vector<int> dis(N+1);
    for(int i=1; i <= N; ++i){
        cin >> x;
        sum += x;
        dis[i] = sum;
    }
    cin >> cnt;
    int st = 0, en = 0;
    for(int i=0; i<cnt; ++i){
        cin >> st >> en;
        if(st > en) swap(st, en);
        int temp = dis[en - 1] - dis[st - 1];
        cout << min(temp, sum - temp) << endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值