PAT甲 1051 Pop Sequence (25 分)

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, …, N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:
Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:
For each pop sequence, print in one line “YES” if it is indeed a possible pop sequence of the stack, or “NO” if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO

模拟栈的入栈出栈,读取输出序列的同时,将输入栈的顺序同时考虑。
①若输出序列的元素等于当前输入栈的元素,则直接跳过
②若输出序列的元素等于栈顶元素,则栈pop移出一个元素
③若均不满足以上两点,则执行入栈操作,直到入栈元素等于此时输出序列的元素,在过程中,若栈的大小超过n则返回false。

#include<iostream>
#include<stack>
using namespace std;

int main() {
	int n, m, k,t;
	cin >> n >> m >> k;
	stack<int> S;
	while (k--) {
		while (!S.empty()) S.pop();
		bool f = true;
		int j = 1;
		for (int i = 1; i <= m; i++) {
			cin >> t;		
			if (t == j) {
				j++;
				continue;
			}
			else if (!S.empty()) {
				if (S.top() == t) {
					S.pop();
					continue;
				}
			}
			if (S.empty()||S.top()!=t){
				if (j > m) {
					f = false;
				}
				else {
					while (j <= m) {
						if (j != t) {
							S.push(j);
							j++;
						}
						else {
							j++;
							break;
						}
						if (S.size() >= n) f = false;
					}
				}
			}
		}
		if (f) cout << "YES" << endl;
		else cout << "NO" << endl;
	}
	return 0;
}

欢迎指导和交流!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值