Molar mass(求C6H5OH等的质量)

An organic compound is any member of a large class of chemical
compounds whose molecules contain carbon. The molar
mass of an organic compound is the mass of one mole of the
organic compound. The molar mass of an organic compound
can be computed from the standard atomic weights of the
elements.
When an organic compound is given as a molecular formula,
Dr. CHON wants to find its molar mass. A molecular
formula, such as C3H4O3, identifies each constituent element by
its chemical symbol and indicates the number of atoms of each
element found in each discrete molecule of that compound. If
a molecule contains more than one atom of a particular element,
this quantity is indicated using a subscript after the chemical symbol.
In this problem, we assume that the molecular formula is represented by only four elements, ‘C’
(Carbon), ‘H’ (Hydrogen), ‘O’ (Oxygen), and ‘N’ (Nitrogen) without parentheses.
The following table shows that the standard atomic weights for ‘C’, ‘H’, ‘O’, and ‘N’.
Atomic Name Carbon Hydrogen Oxygen Nitrogen
Standard Atomic Weight 12.01 g/mol 1.008 g/mol 16.00 g/mol 14.01 g/mol
For example, the molar mass of a molecular formula C6H5OH is 94.108 g/mol which is computed by
6 × (12.01 g/mol) + 6 × (1.008 g/mol) + 1 × (16.00 g/mol).

Given a molecular formula, write a program to compute the molar mass of the formula.
Input
Your program is to read from standard input. The input consists of T test cases. The number of test
cases T is given in the first line of the input. Each test case is given in a single line, which contains
a molecular formula as a string. The chemical symbol is given by a capital letter and the length of
the string is greater than 0 and less than 80
. The quantity number n which is represented after the
chemical symbol would be omitted when the number is 1 ( 2 ≤ n ≤ 99 ).
Output
Your program is to write to standard output. Print exactly one line for each test case. The line should
contain the molar mass of the given molecular formula.
Sample Input
4
C
C6H5OH
NH2CH2COOH
C12H22O11
Sample Output
12.010
94.108
75.070
342.296



看这些英文是不是很烦诶。。。

这个题题意就是

看下边这两个图:
分别给出CHON的质量,让求总质量。。

在这里插入图片描述
在这里插入图片描述

我的思路:先把一行都输入进去,然后倒着遍历:如果是数字,就判断是十位还是各位,处理好数字。如果是字母,就计算,然后数字清零。

AC代码:

#include<bits/stdc++.h>
using namespace std;
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        char a[100];
        scanf("%s",a);
        int len=strlen(a);
        //printf("len=%d\n",len);
        double ans=0.0;
        int wei=1;
        int shu=1;
        for(int i=len-1;i>=0;i--)//倒着遍历
        {
            if(a[i]=='C')
            {
                //printf("%d\n",shu);
                ans += shu*12.01;
                //printf("%.3lf\n",ans);
                shu=1;//遇到字母了,shuwei都是1
                wei=1;
            }
            else if(a[i]=='H')
            {
                ans += shu*1.008;
                //printf("%.3lf\n",ans);
                shu=1;
                wei=1;
            }
            else if(a[i]=='O')
            {
                ans += shu*16.00;
                //printf("%.3lf\n",ans);
                shu=1;
                wei=1;
            }
            else if(a[i]=='N')
            {
                ans += shu*14.01;
                //printf("%.3lf\n",ans);
                shu=1;
                wei=1;
            }
            else //是数字
            {
                int s=a[i]-'0';
                //printf("%d\n",s);
                if(wei==1)//判断是第几位
                {
                    shu=s;//第一位直接存数
                    wei=2;
                }
                else
                {
                    shu += 10*s;//第二位就直接加上十位
                }
            }
        }
        printf("%.3lf\n",ans);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值