Let the Balloon Rise#acm刷题

Let the Balloon Rise#acm刷题

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 153632 Accepted Submission(s): 60940

Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges’ favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) – the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input

5
green
red
blue
red
red
3
pink
orange
pink
0

Sample Output

red
pink

问题分析
输入多个字符串,求出现次数最多的那个字符串,显然需要一个记录颜色种类的东西,和一个记录频率的计数器。
代码说明
我用了结构数组作为颜色记录器,以结构数组的元素个数表明颜色重类,每输入一个字符串a,便检索一遍结构数组以查询是否出现过此字符串,若有,便对相应的计数器加一,若无,则新创一个颜色记录器。

AC的c++代码
#include<iostream>
#include<string>
using namespace std;
struct type
{
	string col;
	int num;
};



int main()
{
	int n = 0;
	while (cin >> n && n != 0)
	{
		type color[1000];
		char a[18];
		int k = 0;
		for (int i = 0; i < n; i++)
		{
			cin >> a;
			int work = 0;
			for (int j = 0; j < k; j++)
			{
				if (a == color[j].col)
				{
					color[j].num++; 
					work = 1;
					break;
				}
			}
			if (work == 0)
			{
				color[k].col = a;
				k++;
			}
		}
		for (int i = 0; i <= k; i++)
		{
			for (int j = i; j <= k; j++)
			{
				if (color[i].num < color[j].num)
				{
					type temp;
					temp = color[i];
					color[i] = color[j];
					color[j] = temp;
				}
			}
		}
		cout << color[0].col << endl;
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值