PAT乙级1081 检查密码//字符串问题都要注意的空格问题

本题要求你帮助某网站的用户注册模块写一个密码合法性检查的小功能。该网站要求用户设置的密码必须由不少于6个字符组成,并且只能有英文字母、数字和小数点 .,还必须既有字母也有数字。
输入格式:
输入第一行给出一个正整数 N(≤ 100),随后 N 行,每行给出一个用户设置的密码,为不超过 80 个字符的非空字符串,以回车结束。

输出格式:
对每个用户的密码,在一行中输出系统反馈信息,分以下5种:

  1. 如果密码合法,输出Your password is wan mei.;
  2. 如果密码太短,不论合法与否,都输出Your password is tai duan le.;
  3. 如果密码长度合法,但存在不合法字符,则输出Your password is tai luan le.;
  4. 如果密码长度合法,但只有字母没有数字,则输出Your password needs shu zi.;
  5. 如果密码长度合法,但只有数字没有字母,则输出Your password needs zi mu.。

输入样例:
5
123s
zheshi.wodepw
1234.5678
WanMei23333
pass*word.6

输出样例:
Your password is tai duan le.
Your password needs shu zi.
Your password needs zi mu.
Your password is wan mei.
Your password is tai luan le.

思路:这题很简单,但是如下代码会有一个测试点通过不了

#include <iostream>
#include <string>
#include <cctype>
using namespace std;
int main()
{
	int n;
	cin >> n;
	string pw;
	for (int i = 0; i < n; i++)
	{
		int flag = 0, flag_w = 0, flag_d = 0;
		cin >> pw;
		if (pw.size() < 6)
		{
			cout << "Your password is tai duan le." << endl;
			continue;
		}
		for (int j = 0; j < pw.size(); j++)
		{
			if (!isalpha(pw[j]))
			{
				if (!isdigit(pw[j]))
				{
					if (pw[j] != '.')
						flag = 1;
				}else flag_d = 1;
			}else flag_w = 1;
		}
		if (flag == 1)
		{
			cout << "Your password is tai luan le." << endl;
			continue;
		}
		if (flag_d == 0)
		{
			cout << "Your password needs shu zi." << endl;
			continue;
		}
		if (flag_w == 0)
		{
			cout << "Your password needs zi mu." << endl;
			continue;
		}
		cout << "Your password is wan mei." << endl;
	}
	return 0;
}

这个问题其实之前也遇到过,就是密码输入的字符串之间有可能会带有空格。所以还是要用getline(),同时记得在getline()之前用getchar()消除回车

#include <iostream>
#include <string>
#include <cstdlib>
#include <cctype>
using namespace std;
int main()
{
	int n;
	cin >> n;
	getchar();
	string pw;
	for (int i = 0; i < n; i++)
	{
		int flag = 0, flag_w = 0, flag_d = 0;
		getline(cin, pw);
		if (pw.size() < 6)
		{
			cout << "Your password is tai duan le." << endl;
			continue;
		}
		for (int j = 0; j < pw.size(); j++)
		{
			if (!isalpha(pw[j]))
			{
				if (!isdigit(pw[j]))
				{
					if (pw[j] != '.')
						flag = 1;
				}else flag_d = 1;
			}else flag_w = 1;
		}
		if (flag == 1)
		{
			cout << "Your password is tai luan le." << endl;
			continue;
		}
		if (flag_d == 0)
		{
			cout << "Your password needs shu zi." << endl;
			continue;
		}
		if (flag_w == 0)
		{
			cout << "Your password needs zi mu." << endl;
			continue;
		}
		cout << "Your password is wan mei." << endl;
	}
	system("pause");
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值