PAT甲级1043 Is It a Binary Search Tree//构造二叉查找树//前序后序序列

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in a line YES if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or NO if not. Then if the answer is YES, print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

7
8 6 5 7 10 8 11

Sample Output 1:

YES
5 7 6 8 11 10 8

Sample Input 2:

7
8 10 11 8 6 7 5

Sample Output 2:

YES
11 8 10 7 5 6 8

Sample Input 3:

7
8 6 8 5 10 9 11

Sample Output 3:

NO

题目大意

是给出一段序列,问通过这个序列构造出来的二叉查找树的前序序列是否就是给出的序列,或者这棵二叉排序树的镜像树的前序序列是否就是给出的序列。如果是就输出YES并输出对应的树的后序序列,不是就输出NO。

思路

要写几个函数分别解决几个需求。1.写一个insert函数用来构造二叉查找树;2.写一个mirror_ins函数构造二叉查找树的镜像树;3.pre函数求前序序列;4.post函数求后序序列。
题目所给序列放入数组origin,放入的同时构造二叉查找树和其镜像树,然后分别进行前序遍历,将遍历结果分别放入数组pre和mpre。当pre和origin相等时输出YES,然后后序遍历这棵树,输出后序序列;mpre和origin相等时也进行上述操作,只不过遍历的是镜像版的树;都不相同时输出NO

#include <iostream>
#include <cstdlib>
#include <vector>
using namespace std;
struct node
{
	int val;
	node* left;
	node* right;
};
void insert(node* &root, int v);
void mirror_ins(node* &mroot, int v);
void preorder(node* root, vector<int>&);
void postorder(node* root, vector<int>&);
vector<int> origin, pre, post, mpre, mpost;
int main()
{
	int n;
	node* root = NULL;
	node* mroot = NULL;
	cin >> n;
	for (int i = 0; i < n; i++)
	{
		int num;
		cin >> num;
		origin.push_back(num);
		insert(root, num);
		mirror_ins(mroot, num);
	}
	preorder(root, pre);
	preorder(mroot, mpre);
	if (origin == pre)
	{
		cout << "YES\n";
		postorder(root, post);
		for (int i = 0; i < post.size(); i++)
		{
			cout << post[i];
			if (i < post.size() - 1)
				cout << ' ';
		}
	}
	else if (origin == mpre)
	{
		cout << "YES\n";
		postorder(mroot, mpost);
		for (int i = 0; i < mpost.size(); i++)
		{
			cout << mpost[i];
			if (i < mpost.size() - 1)
				cout << ' ';
		}
	}
	else
		cout << "NO\n";
	system("pause");
	return 0;
}
//构造二叉查找树
void insert(node* &root, int v)
{
	if (root == NULL)
	{
		root = new node;
		root -> val = v;
		root -> left = root -> right = NULL;
		return;
	}
	if (v < root -> val)
		insert(root -> left, v);
	else
		insert(root -> right, v);
}
//构造镜像二叉查找树
void mirror_ins(node* &mroot, int v)
{
	if (mroot == NULL)
	{
		mroot = new node;
		mroot -> val = v;
		mroot -> left = mroot -> right = NULL;
		return;
	}
	if (v < mroot -> val)
		mirror_ins(mroot -> right, v);
	else
		mirror_ins(mroot -> left, v);
}
void preorder(node* root, vector<int>& vec)
{
	if (root == NULL)
		return;
	vec.push_back(root -> val);
	preorder(root -> left, vec);
	preorder(root -> right, vec);
}
void postorder(node* root, vector<int>& vec)
{
	if (root == NULL)
		return;
	postorder(root -> left, vec);
	postorder(root -> right, vec);
	vec.push_back(root -> val);
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值