2020PAT甲级秋季7-3 Left-View of Binary Tree (25分)

37 篇文章 0 订阅

7-3Left-View of Binary Tree(25分)

The left-view of a binary tree is a list of nodes obtained by looking at the tree from left hand side and from top down. For example, given a tree shown by the figure, its left-view is { 1, 2, 3, 4, 5 }
在这里插入图片描述
Given the inorder and preorder traversal sequences of a binary tree, you are supposed to output its left-view.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤20), which is the total number of nodes in the tree. Then given in the following 2 lines are the inorder and preorder traversal sequences of the tree, respectively. All the keys in the tree are distinct positive integers in the range of int.

Output Specification:

For each case, print in a line the left-view of the tree. All the numbers in a line are separated by exactly 1 space, and there must be no extra space at the beginning or the end of the line.

Sample Input:

8
2 3 1 5 4 7 8 6
1 2 3 6 7 4 5 8

Sample Output:

1 2 3 4 5

#include<bits/stdc++.h>
using namespace std;
int N, maxs = -1;
vector<int> in, pre, level[20];
unordered_map<int, int> pos;
void Traversal(int inL, int inR, int preRoot, int levels) {
	if (inL > inR) return ;
	if (levels > maxs) maxs = levels;
	int inRoot = pos[pre[preRoot]];
	level[levels].push_back(in[inRoot]);
	Traversal(inL, inRoot - 1, preRoot + 1, levels + 1);
	Traversal(inRoot + 1, inR, preRoot + inRoot - inL + 1, levels + 1);
}
int main() {
	scanf("%d", &N);
	in.resize(N + 1);
	pre.resize(N + 1);
	for (int i = 1; i <= N; i++) {
		scanf("%d", &in[i]);
		pos[in[i]] = i;
	}
	for (int i = 1; i <= N; i++) {
		scanf("%d", &pre[i]);
	}
	Traversal(1, N, 1, 0);
	for (int i = 0; i <= maxs; i++) {
		if (i != 0) printf(" ");
		printf("%d", level[i][0]);
	}
	return 0;
} 
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值