PAT甲级1086 Tree Traversals Again//中序+前序组建二叉树

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.
Figure 1

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: “Push X” where X is the index of the node being pushed onto the stack; or “Pop” meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

Sample Output:

3 4 2 6 5 1

思路

可以先看这题PAT甲级1020 Tree Traversals//由后序和中序序列确定一棵二叉树
一个栈可以模拟一棵二叉树的先序和中序遍历过程,比如题目中样例的操作:
Push的次序是:1、2、3、4、5、6,所以先序序列就是123456
Pop的次序是:3、2、4、1、6、5,所以中序序列就是324165
可以根据先序+中序得出一棵树,再得出后序序列。
思路就是分别提取先序和中序,然后建造一棵树,最后得出后序序列。

  • non-recursive 非递归的
#include <iostream>
#include <cstdlib>
#include <vector>
#include <string>
using namespace std;
struct node
{
	int val;
	node* left;
	node* right;
};
vector<int> pre;
vector<int> in;
vector<int> ans;
int stack[61];
node* creat(int preL, int preR, int inL, int inR);
void post(node*);
int main()
{
	int n, index = 0;
	cin >> n;
	getchar();
	for (int i = 0; i < 2 * n; i++)
	{
		string op;
		getline(cin, op);
		if (op[1] == 'u')
		{
			int num = stoi(op.substr(5));
			stack[index++] = num;
			pre.push_back(num);
		}
		else
		{
			int num = stack[--index];
			stack[index] = 0;
			in.push_back(num);
		}
	}
	node* root = creat(0, pre.size() -1, 0, in.size() - 1);
	post(root);
	for (int i = 0; i < ans.size(); i++)
	{
		if (i > 0)
			cout << " ";
		cout << ans[i];
	}
	system("pause");
	return 0;
}
node* creat(int preL, int preR, int inL, int inR)
{
	if (preL > preR)
		return NULL;
	node* root = new node;
	root->val = pre[preL];
	int k = 0;
	for (int i = 0; i < in.size(); i++)
	{
		if (in[i] == pre[preL])
		{
			k = i;
			break;
		}
	}
	int num_left = k - inL;
	root->left = creat(preL + 1, preL + num_left, inL, k - 1);
	root->right = creat(preL + num_left + 1, preR, k + 1, inR);
	return root;
}
void post(node* root)
{
	if (!root)
		return;
	post(root->left);
	post(root->right);
	ans.push_back(root->val);
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值