PAT甲级1094 The Largest Generation//BFS

A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (<100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (<N) which is the number of family members who have children. Then M lines follow, each contains the information of a family member in the following format:

ID K ID[1] ID[2] … ID[K]

where ID is a two-digit number representing a family member, K (>0) is the number of his/her children, followed by a sequence of two-digit ID’s of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.

Sample Input:

23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18

Sample Output:

9 4

思路

一代人其实就是同一层的人,求人口最多的一代也就是要求结点最多的一层,其实就是BFS的运用,利用队列,一层一层的计数,然后输出人口最多的那一代。

  • 注意层数是从1开始,且人数和层数最少为1,而不是0
#include <iostream>
#include <cstdlib>
#include <vector>
#include <map>
#include <queue>
using namespace std;
vector<int> tree[101];
void BFS(int);
int main()
{
	int n, m;
	cin >> n >> m;
	for (int i = 0; i < m; i++)
	{
		int id, k;
		cin >> id >> k;
		for (int j = 0; j < k; j++)
		{
			int child;
			cin >> child;
			tree[id].push_back(child);
		}
	}
	BFS(1);
	system("pause");
	return 0;
}
void BFS(int root)
{
	int most = 1, lev_record = 1, lev = 2; //这里most设为0测试点1将会出错,因为至少有一个根结点
	queue<int> que;
	que.push(root);
	while (!que.empty())
	{
		int size = que.size();
		for (int i = 0; i < size; i++)
		{
			int t = que.front();
			for (int j = 0; j < tree[t].size(); j++)
				que.push(tree[t][j]);
			que.pop();
		}
		if (que.size() > most)
		{
			most = que.size();
			lev_record = lev;
		}
		lev++;
	}
	cout << most << " " << lev_record << endl;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值