PAT甲级1127 ZigZagging on a Tree//中序后序建树//水平遍历

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However, if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in “zigzagging order” – that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left. For example, for the following tree you must output: 1 11 5 8 17 12 20 15.
在这里插入图片描述

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
12 11 20 17 1 15 8 5
12 20 17 11 15 8 5 1

Sample Output:

1 11 5 8 17 12 20 15

思路

通过中序后序建树,然后水平遍历,只不过一行正序一行倒序

#include <iostream>
#include <vector>
#include <queue>
#include <algorithm>
using namespace std;
struct node
{
	int val;
	node* left;
	node* right;
	node(int v) : val(v), left(NULL), right(NULL) {}
};
int flag = -1;
vector<int> in, post;
vector<int> ans;
node* creat(int postL, int postR, int inL, int inR);
void levelOrder(node*);
int main()
{
	int N;
	cin >> N;
	for (int i = 0; i < N; i++)
	{
		int num;
		cin >> num;
		in.push_back(num);
	}
	for (int i = 0; i < N; i++)
	{
		int num;
		cin >> num;
		post.push_back(num);
	}
	node* root = creat(0, post.size() - 1, 0, in.size() - 1);
	levelOrder(root);
	for (int i = 0; i < ans.size(); i++)
	{
		if (i != 0)
			cout << " ";
		cout << ans[i];
	}
	system("pause");
	return 0;
}
node* creat(int postL, int postR, int inL, int inR)
{
	if (postL > postR)
		return NULL;
	node* root = new node(post[postR]);
	int k;
	for (k = inL; k <= inR; k++)
		if (in[k] == post[postR])
			break;
	int numL = k - inL;
	root->left = creat(postL, postL + numL - 1, inL, k - 1);
	root->right = creat(postL + numL, postR - 1, k + 1, inR);
	return root;
}
void levelOrder(node* root)
{
	queue<node> Q;
	Q.push(*root);
	while (!Q.empty())
	{
		int size = Q.size();
		vector<int> part;
		for (int i = 0; i < size; i++)
		{
			node* top = &Q.front();
			if (top->left != NULL)
				Q.push(*top->left);
			if (top->right != NULL)
				Q.push(*top->right);
			part.push_back(top->val);
			Q.pop();
		}
		if (flag == -1)
		{
			reverse(part.begin(), part.end());
			flag *= -1;
		}
		else
			flag *= -1;
		for (int i = 0; i < part.size(); i++)
			ans.push_back(part[i]);
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值