PAT甲级1076 Forwards on Weibo//BFS

Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L levels of indirect followers are counted.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤1000), the number of users; and L (≤6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered from 1 to N. Then N lines follow, each in the format:
M[i] user_list[i]
where M[i] (≤100) is the total number of people that user[i] follows; and user_list[i] is a list of the M[i] users that followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated by a space.
Then finally a positive K is given, followed by K UserID’s for query.

Output Specification:

For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can trigger, assuming that everyone who can view the initial post will forward it once, and that only L levels of indirect followers are counted.

Sample Input:

7 3
3 2 3 4
0
2 5 6
2 3 1
2 3 4
1 4
1 5
2 2 6

Sample Output:

4
5

题目大意

在微博中,博主发布的消息会被他的粉丝所转发,接着他粉丝的粉丝又会继续转发,本题要求你计算出一个消息从某个博主开始发布,最终会被多少人看到,首行给出社交网络人数的总数N,转发的层数限制L,在此后的n行中,依次给出1~N号用户的关注对象。按照关注人数,关注1,关注2…的形式给出。最后一行先给出测试对象的个数K,然后给出K个测试对象的id

思路

其实就是有向图的BFS,一个博主发个微博,他的粉丝会转发微博,然后这个粉丝的粉丝们又都会转发微博,也就是把博主当作根结点,然后对以这个博主为根的子图进行bfs(注意BFS的层次受到限制),最后数参与bfs的这个子图上一共有多少结点。这题最后一个测试点很容易超时,我用stl里的map来判断结点是否被访问会超时,换成bool数组就不会

#include <iostream>
#include <cstdlib>
#include <vector>
#include <map>
#include <queue>
using namespace std;
vector<int> Adj[1001];
bool vis[1001];
//map<int, bool> vis;
int steps;
void bfs(int);
int main()
{
	int N;
	cin >> N >> steps;
	for (int i = 1; i <= N; i++)
	{
		int Mi;
		cin >> Mi;
		for (int j = 0; j < Mi; j++)
		{
			int usr;
			cin >> usr;
			Adj[usr].push_back(i);
			//i关注usr,说明usr的粉丝是i
		}
	}
	int K;
	cin >> K;
	for (int i = 0; i < K; i++)
	{
		int num;
		cin >> num;
		fill(vis + 1, vis + N + 1, false); //重置vis数组
		bfs(num);
	}
	system("pause");
	return 0;
}
void bfs(int n)
{
	int step = 0, forwarders = -1; //注意转发者初始为-1,因为会把博主自己算进去
	queue<int> Q;
	Q.push(n);
	vis[n] = true;
	while (!Q.empty() && step <= steps)
	{
		int size = Q.size();
		for (int i = 0; i < size; i++)
		{
			int front = Q.front();
			for (int j = 0; j < Adj[front].size(); j++)
			{
				if (!vis[Adj[front][j]])
				{
					Q.push(Adj[front][j]);
					vis[Adj[front][j]] = true;
				}
			}
			Q.pop();
			forwarders++;
		}
		step++;
	}
	cout << forwarders << endl;
	//vis.clear();
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值