L2-006 树的遍历 (25 分)

7 篇文章 0 订阅
4 篇文章 0 订阅

给定一棵二叉树的后序遍历和中序遍历,请你输出其层序遍历的序列。这里假设键值都是互不相等的正整数。

输入格式:

输入第一行给出一个正整数N(≤30),是二叉树中结点的个数。第二行给出其后序遍历序列。第三行给出其中序遍历序列。数字间以空格分隔。

输出格式:

在一行中输出该树的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。

输入样例:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

输出样例:

4 1 6 3 5 7 2
#include<bits/stdc++.h>
using namespace std;
const int maxn = 1e5+10;
int hea[maxn],mid[maxn],flag=1;
struct dot{
	int self;
	dot *lchi,*rchi;
}temp;
dot* newnode(){
	return new dot();
}
int fun(dot& fa,int l1,int r1,int l2,int r2){
	if(l1>r1) return 0;
	int root=hea[r2];
	int p=l1;
	while(mid[p]!=root) p++;
	if(p>r1){ flag=0;return 0;}
	int cnt=p-l1;
	dot *left=newnode(),*right=newnode();
	fa.self=root;
	(*left).self=fun(*left,l1,p-1,l2,l2+cnt-1);
	if((*left).self!=0) fa.lchi=left;
	(*right).self=fun(*right,p+1,r1,l2+cnt,r2-1);
	if((*right).self!=0) fa.rchi=right;
	return root;
}
void bfs(dot root){
	queue<dot>Q;Q.push(temp);
	int flag=0;
	while(!Q.empty()){
		dot buf=Q.front();Q.pop();
		if(buf.lchi!=NULL) Q.push(*buf.lchi);
		if(buf.rchi!=NULL) Q.push(*buf.rchi);
		if(flag) printf(" ");else flag=1;
		printf("%d",buf.self);
	}
}
int main(){
	// freopen("input.txt","r",stdin);
	// freopen("output.txt","w",stdout);	
	int n;scanf("%d",&n);
    for( int i=0; i<n; i++ ) scanf("%d",&hea[i]);
    for( int i=0; i<n; i++ ) scanf("%d",&mid[i]);
    fun(temp,0,n-1,0,n-1);
    if(flag){
        bfs(temp);
        printf("\n");
    }
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值