L2-006 树的遍历 (25 分)

给定一棵二叉树的后序遍历和中序遍历,请你输出其层序遍历的序列。这里假设键值都是互不相等的正整数。

输入格式:

输入第一行给出一个正整数N(≤30),是二叉树中结点的个数。第二行给出其后序遍历序列。第三行给出其中序遍历序列。数字间以空格分隔。

输出格式:

在一行中输出该树的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。

输入样例:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

输出样例:

4 1 6 3 5 7 2

程序:

#include <cstdio>
#include <queue>
#include <vector>
#include <cstdlib>
using namespace std;
struct node
{
	int data;
	struct node *left,*right;
};
struct node* build(vector<int> in,vector<int> post,int a,int b,int c,int d)
{
	if(a > b) return NULL;
	struct node *root = (struct node*)malloc(sizeof(struct node));
	root->data = post[d];
	int pos = a;
	while(in[pos] != post[d])
		pos++;
	root->left = build(in,post,a,pos-1,c,c+pos-a-1);
	root->right = build(in,post,pos+1,b,c+pos-a,d-1);
	return root;
}
void level(struct node* root)
{
	queue<struct node*> q;
	q.push(root);
	vector<int> lorder;
	while(!q.empty())
	{
		struct node *temp = q.front();
		q.pop();
		lorder.push_back(temp->data);
		if(temp->left)
			q.push(temp->left);
		if(temp->right)
			q.push(temp->right);
	}
	for(int i = 0; i < lorder.size(); i++)
	{
		if(i == 0)
			printf("%d",lorder[i]);
		else 
			printf(" %d",lorder[i]);
	}
	printf("\n");
}
int main()
{
	int n;
	scanf("%d",&n);
	vector<int> in(n),post(n);
	for(int i = 0; i < n; i++)
		scanf("%d",&post[i]);
	for(int i = 0; i < n; i++)
		scanf("%d",&in[i]);
	struct node* root = build(in,post,0,n-1,0,n-1);
	level(root);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值