PAT (Advanced Level) Practice 1050 String Subtraction

【Problem Description】:
Given two strings S​1 ​​and S2​​, S=S1​​−S​2 ​​is defined to be the remaining string after taking all the characters in S​2 ​​from S1​​. Your task is simply to calculate S1−S​2 ​​for any given strings. However, it might not be that simple to do it fast.
【Input Specification】:
Each input file contains one test case. Each case consists of two lines which gives S1 and S​2​​, respectively. The string lengths of both strings are no more than 10​4​​. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.
【Output Specification】:
For each test case, print S1−S​2 in one line.
【Sample Input 1】:
They are students.
aeiou
【Sample Output 1】:
Thy r stdnts.

【C++代码】

#include <iostream>
#include <set>
#include <string>
#include <cctype>
using namespace std;
int main() {
	set<char> s;
	string s1,s2;
	getline(cin,s1);
	getline(cin,s2);
	for(int i=0; i<s2.size(); i++) {
		s.insert(s2[i]);
	}
	for(int i=0; i<s1.size(); i++) {
		if(s.find(s1[i])==s.end()) {
			cout<<s1[i];
		}
	}
	return 0;
}

【Java代码】(有两组数据超时)

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
public class Main {
	public static void main(String[] args) throws IOException {
		BufferedReader reader = new BufferedReader(new InputStreamReader(System.in));
		String s1 = reader.readLine();
		String s2 = reader.readLine();
		char ch[] = s2.toCharArray();
		for(char c : ch) {
			s1 = s1.replaceAll(String.valueOf(c),"");
		}
		System.out.println(s1);
	}
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值