POJ2828-Buy Tickets

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input
There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i (1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Vali are as follows:

Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.
There no blank lines between test cases. Proceed to the end of input.

Output
For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input
4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492
Sample Output
77 33 69 51
31492 20523 3890 19243
Hint
The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.

在这里插入图片描述

分析:

题意:
第一行给出一个整数,表示队列中人的个数,然后是n行输入,每行两个整数(i,id),表示名字为id的人插队插到第i个人之后,求队列的排列方式。

解析:
我们用结构体记录离线数据:

struct node{
	int num,id;//num:记录他插到第几个数之后	id:记录该数据的标号
};
node book[N];//记录离线数据

由题意可知,最后插入的位置即为他的准确位置,即在第book[n].num+1个位置(他的前面有book[i].num个数据,我们对这些数据是未知的,即表示为空格);我们忽略已经插入的第n个数据,插入第n-1个数据,他的位置也是确定的:book[n-1].num+1,在他之前有book[n-1].num个数据(不包括已经插入的数据,因为我们按顺序插入的话,逆插已经插入的数据并未出现),即有book[n-1].num个空格,以此类推,我们就可以用线段树或者树状数组维护空格的数量!

代码:(线段树)

#include<iostream>
#include<cstdio>
#define N 200005

using namespace std;

struct node{
	int num,id;
};

node book[N];
int list[N];
int tree[N<<2];

void build(int l,int r,int i)
{
	tree[i]=r-l+1;
	if(l==r)
		return;
	int mid=(l+r)>>1;
	build(l,mid,i<<1);
	build(mid+1,r,i<<1|1);
}

int query(int l,int r,int i,int num)
{
	tree[i]--;
	if(l==r)
		return l;
	int mid=(l+r)>>1;
	if(tree[i<<1]>num)
		return query(l,mid,i<<1,num);
	else
		return query(mid+1,r,i<<1|1,num-tree[i<<1]);
}


int main()
{
	int n,num,id;
	while(cin>>n&&n)
	{
		build(1,n,1);
		for(int i=1;i<=n;i++)
		{
			scanf("%d%d",&book[i].num,&book[i].id);
		}
		for(int i=n;i>0;i--)
		{
			list[query(1,n,1,book[i].num)]=book[i].id;
		}
		for(int i=1;i<n;i++)
		{
			printf("%d ",list[i]);
		}
		printf("%d\n",list[n]);
	}
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值