UVA-129 Krypton Factor (暴力枚举子列)

UVA-129 Krypton Factor (暴力枚举子列)

You have been employed by the organisers of a Super Krypton Factor Contest in which contestants
have very high mental and physical abilities. In one section of the contest the contestants are tested on
their ability to recall a sequenace of characters which has been read to them by the Quiz Master. Many
of the contestants are very good at recognising patterns. Therefore, in order to add some difficulty to
this test, the organisers have decided that sequences containing certain types of repeated subsequences
should not be used. However, they do not wish to remove all subsequences that are repeated, since in
that case no single character could be repeated. This in itself would make the problem too easy for the
contestants. Instead it is decided to eliminate all sequences containing an occurrence of two adjoining
identical subsequences. Sequences containing such an occurrence will be called “easy”. Other sequences
will be called “hard”.
For example, the sequence ABACBCBAD is easy, since it contains an adjoining repetition of the
subsequence CB. Other examples of easy sequences are:
• BB
• ABCDACABCAB
• ABCDABCD
Some examples of hard sequences are:
• D
• DC
• ABDAB
• CBABCBA
In order to provide the Quiz Master with a potentially unlimited source of questions you are asked
to write a program that will read input lines from standard input and will write to standard output.
Input
Each input line contains integers n and L (in that order), where n > 0 and L is in the range 1 ≤ L ≤ 26.
Input is terminated by a line containing two zeroes.
Output
For each input line prints out the n-th hard sequence (composed of letters drawn from the first L letters
in the alphabet), in increasing alphabetical order (Alphabetical ordering here corresponds to the normal
ordering encountered in a dictionary), followed (on the next line) by the length of that sequence. The
first sequence in this ordering is ‘A’. You may assume that for given n and L there do exist at least n
hard sequences.
As such a sequence is potentially very long, split it into groups of four (4) characters separated by
a space. If there are more than 16 such groups, please start a new line for the 17th group.
Your program may assume a maximum sequence length of 80.
For example, with L = 3, the first 7 hard sequences are:
A
AB
ABA
ABAC
ABACA
ABACAB
ABACABA
Sample Input
7 3
30 3
0 0
Sample Output
ABAC ABA
7
ABAC ABCA CBAB CABA CABC ACBA CABA
28

按照字典序找到第n个Krypton Factor(定义:没有两个连续子序列相同),dfs以此往后添加字符,并检查是否是Krypton Factor,因为前边都已经检查过,所以只用检查含刚添加进来的字符的子串

#include <cstring>
#include <cstdio>
using namespace std;
int n,l, cnt;
char s[100];

bool hard(int step){
    for(int i = 1; i <= (step+1)/2; i++){
        int ok = 1;
        int s1 = step, s2 = step-i, j = 1;
        //s1,s2分别为两个子串的尾巴,往前检查。
        while( j<=i){
            if(s[s1] != s[s2]) {
                ok = 0;//发现一个字符不一样,那就不是Krypton Factor。
                break;
            }
            s1--;s2--;j++;
        }
        if(ok) return false;
    }
    return true;
}
int dfs(int step){
    if(cnt == n){
        int len = strlen(s);
        for(int i = 0; i < len; i++)
            if(i!= 0 && i%64==0) printf("\n%c",s[i]);
            else if(i!=0 && i%4==0) printf(" %c",s[i]);
            else printf("%c",s[i]);
        printf("\n%d\n",len);
        return 1;
    }else{
        for(int i = 0; i<l; i++){
            s[step] = (char)('A'+i);
            if(hard(step)) {
                cnt++;
                if(dfs(step+1))
                    return 1;
            }
            s[step] = '\0';
        }
    }
    return 0;
}
int main(){
    while(scanf("%d%d",&n,&l) && n!=0 && l!=0){
        cnt = 0;
        memset(s,'\0',sizeof(s));
        int a = dfs(0);
    }
    return 0;
}

测试数据:https://www.udebug.com/UVa/129

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值