HDU-1078 FatMouse and Cheese (线性DP)

Problem Description
FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he's going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move. 
 

Input
There are several test cases. Each test case consists of 

a line containing two integers between 1 and 100: n and k 
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on. 
The input ends with a pair of -1's. 
 

Output
For each test case output in a line the single integer giving the number of blocks of cheese collected. 
 

Sample Input
 
 
3 1 1 2 5 10 11 6 12 12 7 -1 -1
 

Sample Output
 
 
37
 

题意:给你一个n*n的矩阵,每次最多沿四个直线方向移动k步,起点是(1,1),下一个格子值必须大于上一个,且在合法步数内才能移动,同时累加值,问你最大可以累加多大的值。

思路:状定义dp[i][j]为到达第(i,j)位置时的最优解,当前位置的状态转移来源有4*k个位置:(i-k,j)到(i+k,j)   (i,j-k)到(i,j+k),将这几个位置遍历更新出max的dp[i][j]即为当前位置的最优解。

状态转移并不难想,因此我们可以直接将每个格子按照值,从小到大排序,然后逐个遍历,特别注意起点位置初始化,起点不一定值最小,起点之前的位置不能转移,dp[i][j]为0的即没有值的也不能转移。

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<string>
#include<map>
#include<vector>
#include<queue>
#include<stack>
#include<set>
#include<sstream>
#include<bits/stdc++.h>
#define ll long long
#define lson l,mid,root<<1
#define rson mid+1,r,root<<1|1
using namespace std;
struct node
{
    ll x,y,w;
}ord[10010];
ll a[110][110],dp[110][110],n,k,p;
bool cmp(node p1,node p2)
{
    return p1.w<p2.w;
}
void update(ll sx,ll sy)   //以下是4个方向,注意边界和未求解的地方要跳过
{
    for(ll i=1;i<=k;i++)
    {
        if(sx-i>=1)
        {
            if((a[sx-i][sy]<a[sx][sy])&&(dp[sx-i][sy]))
            {
                dp[sx][sy]=max(dp[sx][sy],a[sx][sy]+dp[sx-i][sy]);
            }
        }
        if(sx+i<=n)
        {
            if((a[sx+i][sy]<a[sx][sy])&&(dp[sx+i][sy]))
            {
                dp[sx][sy]=max(dp[sx][sy],a[sx][sy]+dp[sx+i][sy]);
            }
        }
        if(sy-i>=1)
        {
            if((a[sx][sy-i]<a[sx][sy])&&(dp[sx][sy-i]))
            {
                dp[sx][sy]=max(dp[sx][sy],a[sx][sy]+dp[sx][sy-i]);
            }
        }
        if(sy+i<=n)
        {
            if((a[sx][sy+i]<a[sx][sy])&&(dp[sx][sy+i]))
            {
                dp[sx][sy]=max(dp[sx][sy],a[sx][sy]+dp[sx][sy+i]);
            }
        }
    }
}
int main()
{
    while(~scanf("%lld%lld",&n,&k))
    {
        if(n==-1&&k==-1)break;
        p=1;
        for(ll i=1;i<=n;i++)
        {
            for(ll j=1;j<=n;j++)
            {
                scanf("%lld",&a[i][j]);
                ord[p].w=a[i][j];
                ord[p].x=i;
                ord[p].y=j;
                p++;
            }
        }
        sort(ord+1,ord+p,cmp);   
        memset(dp,0,sizeof(dp));
        ll ans=dp[1][1]=a[1][1];   //初始化起点
        for(ll i=1;i<p;i++)
        {
            update(ord[i].x,ord[i].y);    //每到一个新位置,更新求解最优解
            ans=max(ans,dp[ord[i].x][ord[i].y]);   //保存最大值
        }
        printf("%lld\n",ans);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值