Uva 122 二叉树BFS

 Trees are fundamental in many branches of computer science. Current state-of-the art parallel computers such as Thinking Machines' CM-5 are based on fat trees. Quad- and octal-trees are fundamental to many algorithms in computer graphics.

This problem involves building and traversing binary trees.
Given a sequence of binary trees, you are to write a program that prints a level-order traversal of each tree. In this problem each node of a binary tree contains a positive integer and all binary trees have have fewer than 256 nodes.

In a level-order traversal of a tree, the data in all nodes at a given level are printed in left-to-right order and all nodes at level k are printed before all nodes at level k+1.

For example, a level order traversal of the tree


is: 5, 4, 8, 11, 13, 4, 7, 2, 1.

In this problem a binary tree is specified by a sequence of pairs (n,s) where n is the value at the node whose path from the root is given by the string s. A path is given be a sequence of L's and R's where L indicates a left branch and R indicates a right branch. In the tree diagrammed above, the node containing 13 is specified by (13,RL), and the node containing 2 is specified by (2,LLR). The root node is specified by (5,) where the empty string indicates the path from the root to itself. A binary tree is considered to be completely specified if every node on all root-to-node paths in the tree is given a value exactly once.

Input
The input is a sequence of binary trees specified as described above. Each tree in a sequence consists of several pairs (n,s) as described above separated by whitespace. The last entry in each tree is (). No whitespace appears between left and right parentheses.

All nodes contain a positive integer. Every tree in the input will consist of at least one node and no more than 256 nodes. Input is terminated by end-of-file.

Output
For each completely specified binary tree in the input file, the level order traversal of that tree should be printed. If a tree is not completely specified, i.e., some node in the tree is NOT given a value or a node is given a value more than once, then the string ``not complete’’ should be printed
Sample Input

(11,LL) (7,LLL) (8,R)
(5,) (4,L) (13,RL) (2,LLR) (1,RRR) (4,RR) ()
(3,L) (4,R) ()

Sample Output

5 4 8 11 13 4 7 2 1
not complete
用链式结构来构建二叉树,最后用BFS的方法来保存答案
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<vector>
#include<iostream>
#include<queue>
using namespace std;
char s[100100];int flag = 1;
struct Node
{
    bool have_value;
    int v;
    Node *lefta,*righta;
    Node():have_value(false),lefta(NULL),righta(NULL){} 
};
Node * root;
Node * newnode() {return new Node();}
void addnode(int v,char *s)
{
    int len = strlen(s);
    Node *u = root;
    for(int i = 0; i < len; i++)
    {
        if(s[i] == 'L')
        {
            if(u->lefta == NULL)
                u->lefta = newnode();
            u = u->lefta;
        }
        else if(s[i] == 'R')
        {
            if(u->righta == NULL)
                u->righta = newnode();
            u = u->righta;
        }
    }
    if(u->have_value)
        flag = 0;
    u->v = v;
    u->have_value = true;
}
bool read_input()
{
    flag = 1;
    root = newnode();
    while(1)
    {
        if(scanf("%s",s)!=1)
            return false;
        if(!strcmp(s,"()"))
            break;
        int v;
        sscanf(&s[1],"%d",&v);
        addnode(v, strchr(s,',')+1);
    }
    return true;
}
bool bfs(vector<int>& ans)
{
    queue<Node*> q;
    ans.clear();
    q.push(root);
    while(!q.empty())
    {
        Node* u = q.front();
        q.pop();
        if(!u->have_value)
            return false;
        ans.push_back(u->v);
        if(u->lefta != NULL)
            q.push(u->lefta);
        if(u->righta != NULL)
            q.push(u->righta);
    }
    return true;
}
int main()
{
    vector<int> ans;
    while(read_input())
    {
        if(!bfs(ans))
            flag = 0;
        if(flag==0)
            printf("not complete\n");
        else
        {
            for(int i = 0; i < ans.size(); i++)
            {
                if(i==ans.size()-1)
                    printf("%d\n",ans[i]);
                else
                    printf("%d ",ans[i]);
            }
        }
    }
    return 0;
}

亦可以用数组来实现

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<vector>
#include<queue>
using namespace std;
const int maxn=256+10;
const int root=1; 
bool failed;
int cnt=1;
int left[maxn];
int right[maxn];
int value[maxn];
bool have_value[maxn];
int newnode()
{
    int u=++cnt; left[u]=0;
    right[u]=0;  have_value[u]=false;
    return u;
}
bool addnode(int v,char* s)
{
    int n=strlen(s),t=root;
    for(int i=0;i<n;i++)
    {
        if(s[i]=='L')
        {
        if(left[t]==0) left[t]=newnode();
        t=left[t];
        }
        if(s[i]=='R')
        {
        if(right[t]==0)right[t]=newnode();
        t=right[t];
        }
    }
    if(have_value[t]==true) failed=true;
    else have_value[t]=true;
    value[t]=v;
    return true;
}
void newtree(){             //相当于动态里newnode结构体拆开,因为是静态数组,无需申请内存 
    cnt=root;
    right[root]=0;
    left[root]=0;
    have_value[root]=false;
}
char s[maxn];
bool input_read(){
    failed = false;
    newtree();
    int v;
    for(;;)
    {
    if(scanf("%s",s)!=1) return false;
    if(!strcmp(s,"()"))  break;
    sscanf(&s[1],"%d",&v);
    addnode(v,strchr(s,',')+1);
    }
    return true;
}
bool bfs(vector<int>& ans){
    ans.clear();
    queue <int> qcnt;
    int u=1;
    qcnt.push(u);
    while(!qcnt.empty()){
        u=qcnt.front();
        if(have_value[u]==false){return false;}
        qcnt.pop();
        ans.push_back(value[u]);
        if(left[u]!=0)qcnt.push(left[u]);
        if(right[u]!=0)qcnt.push(right[u]);
    }
    return true;
}
int main(){
    memset(have_value,false,sizeof(have_value));
    memset(left,0,sizeof(left));
    memset(right,0,sizeof(right));
    vector <int> ans;
    while(input_read())
    {
        if(!bfs(ans)) failed=true;
        if(failed) printf("not complete\n");
        else 
        {
            for(int i=0;i<ans.size();i++)
            {
                if(i!=0)printf(" ");
                printf("%d",ans[i]);
            }
            printf("\n");
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值