POJ 3252:Round Numbers【数位DP】

Discription

The cows, as you know, have no fingers or thumbs and thus are unable to play Scissors, Paper, Stone’ (also known as ‘Rock, Paper, Scissors’, ‘Ro, Sham, Bo’, and a host of other names) in order to make arbitrary decisions such as who gets to be milked first. They can’t even flip a coin because it’s so hard to toss using hooves.

They have thus resorted to “round number” matching. The first cow picks an integer less than two billion. The second cow does the same. If the numbers are both “round numbers”, the first cow wins,
otherwise the second cow wins.

A positive integer N is said to be a “round number” if the binary representation of N has as many or more zeroes than it has ones. For example, the integer 9, when written in binary form, is 1001. 1001 has two zeroes and two ones; thus, 9 is a round number. The integer 26 is 11010 in binary; since it has two zeroes and three ones, it is not a round number.

Obviously, it takes cows a while to convert numbers to binary, so the winner takes a while to determine. Bessie wants to cheat and thinks she can do that if she knows how many “round numbers” are in a given range.

Help her by writing a program that tells how many round numbers appear in the inclusive range given by the input (1 ≤ Start < Finish ≤ 2,000,000,000).

Input

Line 1: Two space-separated integers, respectively Start and Finish.

Output

Line 1: A single integer that is the count of round numbers in the inclusive range Start… Finish

Sample Input

2 12

Sample Output

6

题意
一个数的二进制中0的数量要不能少于1的数量。求在两个数l,r范围内符合条件的数的个数。

思路
dp[pos][num]表示到当前数位pos,0的数量减去1的数量不少于num的方案数。中间某个pos位上num可能为负数(这不一定是非法的,只要最终的num>=0才能判合法)。最小是-32,直接加上32,做0处理。

AC代码

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
int a[66];
int dp[35][66];
int dfs(int pos,int state,bool lead,bool limit)
{
    if(pos==-1)
        return state>=32;///若pos到-1则跳出
    if(!limit && !lead && dp[pos][state]!=-1)
        return dp[pos][state];///若非前导0,并且没有达到上限,但是dp[pos][state]不是-1
    int up=limit?a[pos]:1;///确定遍历上限
    int ans=0;
    for(int i=0; i<=up; i++)
    {
        if(lead&&i==0)
            ans+=dfs(pos-1,state,lead,limit && i==a[pos]);
        else
            ans+=dfs(pos-1,state+(i==0?1:-1),lead && i==0,limit && i==a[pos]);
    }///分情况dfs状态转移
    if(!limit && !lead)
        dp[pos][state]=ans;
    return ans;
}
int solve(int x)
{
    int pos=0;
    while(x)
    {
        a[pos++]=x&1;
        x>>=1;
    }///把每一位取出来
    return dfs(pos-1,32,true,true);
}
int main()
{
    memset(dp,-1,sizeof(dp));
    int le,ri;
    while(~scanf("%d%d",&le,&ri))
    {
        printf("%d\n",solve(ri)-solve(le-1));///上界减去下届,差值就是所要求的。
    }
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值