[数论]HDU 1452 Happy 2004 素因子分解+快速幂模+乘法逆元

传送门:Happy 2004

Happy 2004

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 882    Accepted Submission(s): 620


Problem Description
Consider a positive integer X,and let S be the sum of all positive integer divisors of 2004^X. Your job is to determine S modulo 29 (the rest of the division of S by 29).

Take X = 1 for an example. The positive integer divisors of 2004^1 are 1, 2, 3, 4, 6, 12, 167, 334, 501, 668, 1002 and 2004. Therefore S = 4704 and S modulo 29 is equal to 6.
 

Input
The input consists of several test cases. Each test case contains a line with the integer X (1 <= X <= 10000000). 

A test case of X = 0 indicates the end of input, and should not be processed.
 

Output
For each test case, in a separate line, please output the result of S modulo 29.
 

Sample Input
  
  
1 10000 0
 

Sample Output
  
  
6 10
 

Source

解题报告:

题意:给你一个n,让你求2004^n所有因子(包括1和本身)的和%29.

题解:

s[i]代表i的所有因子之和,那么有以下两个结论

1、当gcd(a,b)=1时,s[a*b]=s[a]*s[b].

2、当p为素数时,s[p^n]=p^0+p^1+……+p^n=(p^(n+1)-1)/(p-1)

知道上面的基本上就OK了

代码如下:

#include<iostream>
#include<cstdio>
using namespace std;
long long pow_mod(long long a,long long b,long long n){
    long long res=1;
    while(b){
        if(b&1) res=res*a%n;
        a=a*a%n;
        b>>=1;
    }
    return res;
}
int main(){
    long long n;
    while(scanf("%lld",&n)&&n){
        long long a,b,c;
        a=(pow_mod(2,2*n+1,29)-1)*1%29;
        b=(pow_mod(3,n+1,29)-1)*15%29;
        c=(pow_mod(167,n+1,29)-1)*18%29;
        printf("%lld\n",(a*b*c)%29);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值