Happy 2004(快速幂取模)(积性函数)

Problem Description
Consider a positive integer X,and let S be the sum of all positive integer divisors of 2004^X. Your job is to determine S modulo 29 (the rest of the division of S by 29).
Take X = 1 for an example. The positive integer divisors of 2004^1 are 1, 2, 3, 4, 6, 12, 167, 334, 501, 668, 1002 and 2004. Therefore S = 4704 and S modulo 29 is equal to 6.
Input
The input consists of several test cases. Each test case contains a line with the integer X (1 <= X <= 10000000).
A test case of X = 0 indicates the end of input, and should not be processed.
Output
For each test case, in a separate line, please output the result of S modulo 29.
Sample Input
1
10000
0
Sample Output
6
10
题目大意就是求2004的X次方的所有因子之和并对29取余。
设S(x)表示x的因子和。则题目求为:S(2004^X)mod 29
因子和S是积性函数,即满足性质1。
性质1 :如果 gcd(a,b)=1 则 S(a*b)= S(a)S(b)
2004X=4X * 3^X 167^X
S(2004X)=S(2(2X)) * S(3^X) * S(167^X)
性质2 :如果 p 是素数 则 S(pX)=1+p+p2+…+p^X = (p^(X+1)-1)/(p-1)
因此:S(2004X)=(2(2X+1)-1) * (3^(X+1)-1)/2 * (167^(X+1)-1)/166
167%29 == 22
S(2004X)=(2(2X+1)-1) * (3^(X+1)-1)/2 * (22^(X+1)-1)/21
性质3 :(a
b)/c %M= a%M * b%M * inv©
其中inv©即满足 (c
inv©)%M=1的最小整数,这里M=29
则inv(1)=1,inv(2)=15,inv(22)=15
有上得:
S(2004X)=(2(2X+1)-1) * (3^(X+1)-1)/2 * (22^(X+1)-1)/21
=(2^(2X+1)-1) * (3^(X+1)-1)*15 * (22^(X+1)-1)*18

#include<stdio.h>
long long poww(long long a,long long b)     //快速幂取模 
{
	int ans=1;
	a=a%29;
	while(b>0)
	{
		if(b%2==1) ans=(ans*a)%29;
		b=b/2;
		a=(a*a)%29;
	}
	return ans;
}
int main()
{
	long long x;
	long long n,i;
	while(scanf("%lld",&x)!=EOF)
	{
		if(x==0) break;
		int a=poww(2,2*x+1);
		int b=poww(3,x+1);
		int c=poww(22,x+1);
		int s=(a-1)*(b-1)*(c-1)*15*18%29;
		printf("%d\n",s);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值