vector的用法

1.vector的定义

1.vector<int> name;
2.vector<vector<int> > name;   // int> >  之间需要加空格,否则会被视为右移
3.vector<int> name[10];

注意2与3的区别,两者均为定义二维数组,即vector中的元素也是vector,区别是vector<vector<int> > name的长度是不固定的,vector<int> name[10]第一维的个数为10

2.vector中元素的访问

(1)通过下边

(2)使用迭代器

vector<char>::iterator it=vi.begin();

这样就把vi的第一个元素的地址给了变量it

(3)注意

只有vector和string可以使用*(it+i)的形式访问元素

vector<char>::iterator it=vi.begin();
*(it+i)

同时,迭代器不支持it<vi.end()

it<vi.end()  //并不支持这种写法
for(vector<int>::iterator it=vi.begin();it !=vi.end();it++)  //应该使用这种形式

3.vector的常用函数

(1)push_back()

(2)pop_back()

向量容器vector的成员函数pop_back()可以删除最后一个元素.并不真正从vertor里面移走数据。

#include<iostream>
#include<vector>
using namespace std;
int main(){
	vector<char> vi;
	for(int i=65;i<90;i++){
		vi.push_back(i);
	}
	vector<char>::iterator it=vi.begin();
	for(int i=0;i<26;i++){
		printf("%c",*(it+i));
	}
	printf("%d",vi.size());
	vi.pop_back();
	printf("%d",vi.size());
	vector<char>::iterator ti=vi.begin();
	for(int i=0;i<vi.size()+2;i++){        //向量容器vector的成员函数pop_back()可以删除最后一个元素.并不真正从vertor里面移走数据。
		printf("%c",*(ti+i));
	}
	
}

使用vi.size()+2,最有一次也会打印出删除掉的元素,说明并不是真正的删除掉了

 

1.问题 A: Course List for Student (25)

题目描述

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

输入

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=40000), the number of students who look for their course lists, and K (<=2500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students Ni (<= 200) are given in a line. Then in the next line, Ni student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

输出

For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student's name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

样例输入

11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9

样例输出

ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0

分析:

本题是输入每节课的学生名单,要求输出每个同学有几节课,以及是哪些课,因此我们需要建立一个vextor,同时将名字转换为hash,将每个hash所对应的课的编号存入vector中,从而可以得到总的课

代码:

#include<iostream> 
#include<vector>
#include<string>
#include<algorithm>
using namespace std;
const int maxn=180000;
vector<int> list[maxn];
int strtoint(char a[]){
	return (a[0]-'A')*26*26*10+(a[1]-'A')*26*10+(a[2]-'A')*10+a[3]-'0';
}
int main(){
	int namenum,classnum;
	char name[5];
	scanf("%d%d",&namenum,&classnum);
	while(classnum--){
		int a,b;
		scanf("%d%d",&a,&b);
		while(b--){
			scanf("%s",name);
			int idx=strtoint(name);
			list[idx].push_back(a);
		}
	}
	while(namenum--){
		scanf("%s",name);
		int idy=strtoint(name);
		printf("%s %d ",name,list[idy].size());
		sort(list[idy].begin(),list[idy].end());
		for(int i=0;i<list[idy].size();i++){
			printf("%d ",list[idy][i]);
		}
		if(namenum) printf("\n");
	}
}

 

2.问题 B: Student List for Course (25)

题目描述

Zhejiang University has 40000 students and provides 2500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses.

输入

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=40000), the total number of students, and K (<=2500), the total number of courses. Then N lines follow, each contains a student's name (3 capital English letters plus a one-digit number), a positive number C (<=20) which is the number of courses that this student has registered, and then followed by C course numbers. For the sake of simplicity, the courses are numbered from 1 to K.

输出

For each test case, print the student name lists of all the courses in increasing order of the course numbers. For each course, first print in one line the course number and the number of registered students, separated by a space. Then output the students' names in alphabetical order. Each name occupies a line.

样例输入

10 5
ZOE1 2 4 5
ANN0 3 5 2 1
BOB5 5 3 4 2 1 5
JOE4 1 2
JAY9 4 1 2 5 4
FRA8 3 4 2 5
DON2 2 4 5
AMY7 1 5
KAT3 3 5 4 2
LOR6 4 2 4 1 5

样例输出

1 4
ANN0
BOB5
JAY9
LOR6
2 7
ANN0
BOB5
FRA8
JAY9
JOE4
KAT3
LOR6
3 1
BOB5
4 7
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
5 9
AMY7
ANN0
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1

分析

这道题是将第一道题反了过来,输入每个学生的课表,要求输出每节课有哪些同学上,因此建立vector数组,以课程的编号为下标,将学生的姓名存放在vector中。

代码:

#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
const int maxn=10000;
vector<string> list[maxn];
int main(){
	int nump,numc;
	char name[4];
	scanf("%d%d",&nump,&numc);
	while(nump--){
		int a,b;
		scanf("%s %d",name,&a);
		for(int i=0;i<a;i++){
			scanf("%d",&b);
			list[b].push_back(name);
		}
	}
	for(int i=1;i<6;i++){
		printf("%d %d\n",i,list[i].size());
		sort(list[i].begin(),list[i].end());
		for(int j=0;j<list[i].size();j++){
			printf("%s\n",list[i][j].c_str());
		} 
	}
}

总结:

在printf中,要输出string所定义的变量,要使用以下的形式

printf("%s\n",list[i][j].c_str());

而在cout中,直接采用即可

cout<<list[i][j] <<endl;

 

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值