A - Let the Balloon Rise

A - Let the Balloon Rise

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input

5
green
red
blue
red
red
3
pink
orange
pink
0

Sample Output

red
pink

题目很长,还是一堆英文咱也看不懂,还好咱有网页翻译哈哈哈。题目大意输入多个字符串,找到出现次数最多的字符串

需要定义一个二维字符数组,关于二维字符数组的说明https://blog.csdn.net/weixin_43537574/article/details/94913247

#include<stdio.h>
#include<string.h> 
int main()
{
	int a[1001],i,n;
	char str[1001][15];//定义二维字符数组
	while(scanf("%d",&n)&&n!=0)
	{
		getchar();//清空输入缓冲区的回车
		int max=0,index=0;
		for(i=0;i<n;i++)
		{
			scanf("%s",&str[i]);
		}
		for(i=0;i<n;i++)
		{
			a[i]=0;
			for(int j=i;j<n;j++)
			{
				if(strcmp(str[i],str[j])==0)
				a[i]++;//统计每个字符串出现次数
			}
			
		
		if(a[i]>max)
			{max=a[i];
			index=i;
			}
		}
			printf("%s\n",str[index]);
	}
	return 0;
}

 

C++做法用map统计出现次数最多颜色数量

#include<iostream>
#include<string>
#include<map>
using namespace std;
int main()
{
	string s,a[1001],ans;
	int n;
	map<string,int>mp;
	while(cin>>n&&n)
	{
		int max=0;
		for(int i=0;i<n;i++)
		{
			cin>>s,mp[s]++,a[i]=s;//统计单词个数 
		}
	    for(int i=0;i<n;i++)
	    {
		 if(mp[a[i]]>max)
		 {
		 	max=mp[a[i]];
		 	ans=a[i];
		 }
	    }
		 cout<<ans<<endl; 
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值