1005 大数加法

给出2个大整数A,B,计算A+B的结果。
输入
第1行:大数A
第2行:大数B
(A,B的长度 <= 10000 需注意:A B有可能为负数)
输出
输出A + B

输入样例
68932147586
468711654886
输出样例
537643802472
#include<bits/stdc++.h>
using namespace std;
struct node{
 int d[10010];
 int len;
 bool f;
 node(){memset(d,0,sizeof(d));}
 node(char*s)
 {
  memset(d,0,sizeof(d));
  if(s[0]=='-') f=1,s++;
  else f=0;
  int i=0;
  while(s[i]!='\0')
   d[i]=s[i]-'0',++i;
  len=i;
  for(int i=0,j=len-1;i<j;i++,j--)
   swap(d[i],d[j]);
 }
 bool operator<(const node&t)const
 {
  if(this->len==t.len)
   for(int i=t.len-1;i>=0;i--)
    if(this->d[i]<t.d[i])
     return true;
    else if(this->d[i]>t.d[i])
     return false;
  return this->len<=t.len;
 }
 node operator+(const node &t)const
 {
  node ans;
  if(t.f==this->f)
  {
   ans.f=this->f;
   int len=max(t.len,this->len);
   ans.len=len;
   for(int i=0;i<len;i++)
   {
    ans.d[i]+=this->d[i]+t.d[i];
  ans.d[i+1]+=ans.d[i]/10;
  ans.d[i]%=10; 
   }
   if(ans.d[len]!=0)
    ans.len++;
  } 
  else
  {
   if(t<(*this))
    ans=(*this)-t;
   else
    ans=t-(*this);
  }
  return ans;
 }
 node operator-(const node &t) const
 {
  node ans;
  ans.f=this->f;
  int len=this->len;
  ans.len=len;
  for(int i=0;i<len;i++)
  {
   ans.d[i]+=this->d[i]-t.d[i];
   if(ans.d[i]<0)
    ans.d[i]+=10,ans.d[i+1]--;
  }
  while(ans.len>1&&ans.d[ans.len-1]==0)
   ans.len--;
  return ans;
 }
};
char str[10009];
int main()
{
 cin>>str;
 node a(str);
 cin>>str;
 node b(str);
 node ans=a+b;
 if(ans.f) cout<<'-';
 for(int i=ans.len-1;i>=0;i--)
  cout<<ans.d[i];
 return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值