balance (枚举dp)

这篇博客探讨了一个独特的平衡设备,它由两条等长的臂组成,上面挂有钩子,Gigel需要使用他的G个不同重量的砝码(1到25的不重复值)来平衡它。博客介绍了如何计算平衡设备的所有可能方式,考虑到钩子的位置和砝码的权重,保证至少有一个解决方案。文章内容包括输入格式(包含钩子分布和砝码重量),并指出存在至少一种平衡方法。
摘要由CSDN通过智能技术生成

Gigel has a strange “balance” and he wants to poise it. Actually, the device is different from any other ordinary balance.

It orders two arms of negligible weight and each arm’s length is 15. Some hooks are attached to these arms and Gigel wants to hang up some weights from his collection of G weights (1 <= G <= 20) knowing that these weights have distinct values in the range 1…25. Gigel may droop any weight of any hook but he is forced to use all the weights.

Finally, Gigel managed to balance the device using the experience he gained at the National Olympiad in Informatics. Now he would like to know in how many ways the device can be balanced.

Knowing the repartition of the hooks and the set of the weights write a program that calculates the number of possibilities to balance the device.

It is guaranteed that will exist at least one solution for each test case at the evaluation.

    Input
    
  
   The input has the following structure: 

• the first line contains the number C (2 <= C <= 20) and the number G (2 <= G <= 20);

• the next line contains C integer numbers (these numbers are also distinct and sorted in ascending order) in the range -15…15 representing the repartition of the hooks; each number represents the position relative to the center of the balance on the X axis (when no weights are attached the device is balanced and lined up to the X axis; the absolute value of the distances represents the distance between the hook and the balance center and the sign of the numbers determines the arm of the balance to which the hook is attached: ‘-’ for the left arm and ‘+’ for the right arm);

• on the next line there are G natural, distinct and sorted in ascending order numbers in the range 1…25 representing the weights’ values.

    Output
    
  
   The output contains the number M representing the number of possibilities to poise the balance. 
  

    Sample Input
    2 4	

-2 3
3 4 5 8

    Sample Output
    2
#include<cstdio>
#include<algorithm>
#include<iostream>
#include<cstring>
using namespace std;
int dp[25][16000];   //重量是1 - 25 存的数
//表示到达这个重量的方法有几种
int c[25],w[25];
int main()
{
    //7500表示平衡的时候
    int n,m,i,j,k;
    cin>>n>>m;
    for(i = 1; i<=n; i++)
        cin>>c[i];//位置
    for(i = 1; i<=m; i++)
        cin>>w[i];//重量
    dp[0][7500] = 1;
    for(i = 1; i<=m; i++)//几个砝码
    {
        for(j = 0; j<=15000; j++)
            if(dp[i-1][j])//一个小小的优化
                for(k = 1; k<=n; k++)//位置
                    dp[i][j+c[k]*w[i]]+=dp[i-1][j];
    }
    for(i = 1; i<=m; i++)//几
        for(j = 0; j<=15000; j++)
            if(dp[i][j])
                printf("dp[%d][%d]=%d \n",i,j,dp[i][j]);
    cout<<dp[m][7500];
    return 0;
}
//? ?????????
//2    4 8               3 4 5
//3    3 5               8
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值