Expanding Rods

传送门

题面:

Expanding Rods

Time Limit: 1000MS
Memory Limit: 30000K
Total Submissions: 19870
Accepted: 5311

When a thin rod of length L is heated n degrees, it expands to a new length L’=(1+n*C)*L, where C is the coefficient of heat expansion.
When a thin rod is mounted on two solid walls and then heated, it expands and takes the shape of a circular segment, the original rod being the chord of the segment.

Your task is to compute the distance by which the center of the rod is displaced.Alt
Input

The input contains multiple lines. Each line of input contains three non-negative numbers: the initial lenth of the rod in millimeters, the temperature change in degrees and the coefficient of heat expansion of the material. Input data guarantee that no rod expands by more than one half of its original length. The last line of input contains three negative numbers and it should not be processed.

Output

For each line of input, output one line with the displacement of the center of the rod in millimeters with 3 digits of precision.

Sample Input

1000 100 0.0001
15000 10 0.00006
10 0 0.001
-1 -1 -1

Sample Output

61.329
225.020
0.000

题面描述:

这根木棍会受热膨胀并向上弯曲,给出了受热膨胀后长度的公式和温度,要求膨胀后弯曲的木棍中点距离原始状态的中点的距离。输入的数据保证杆的长度不会超过原来长度的一半。

题目分析:

正常想数学算法好像是求不出杆中心位移距离的,这时候要用二分一个个枚举,控制精度比题目的1e-3小就行,当二分的左右都在这个精度内随便输出哪个都行。

代码:

#include<algorithm>
#include<stdio.h> 
#include<math.h>
#include<iostream>
using namespace std;
double l,n,c;

int ch(double mid){
	double nlen,nrad,rlen;
	rlen=(1+n*c)*l,nrad=(mid*mid+l*l/4)/(2*mid),nlen=asin((l/2)/nrad)*nrad*2;//rl弧长公式 
	if(rlen>nlen) return 1;
	else return 0;
}


int main(){
	double al,ar,mid;
	while(scanf("%lf %lf %lf",&l,&n,&c)&&l>=0&&n>=0&&c>=0){
		al=0,ar=l/2;
		while(ar-al>0.0001){
			mid=(al+ar)/2;
			if(ch(mid)) al=mid;
			else ar=mid;
		}
		printf("%.3lf\n",al);
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Yjonben

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值