Description
When a thin rod of length L is heated n degrees, it expands to a new length L' = (1+n*C)*L, where C is the coefficient of heat expansion.
When a thin rod is mounted on two solid walls and then heated, it expands and takes the shape of a circular segment, the original rod being the chord of the segment.
Your task is to compute the distance by which the center of the rod is displaced. That means you have to calculate h as in the picture.
Input
Input starts with an integer T (≤ 20), denoting the number of test cases.
Each case contains three non-negative real numbers: the initial length of the rod in millimeters L, the temperature change in degrees n and the coefficient of heat expansion of the material C. Input data guarantee that no rod expands by more than one half of its original length. All the numbers will be between 0 and 1000 and there can be at most 5 digits after the decimal point.
Output
For each case, print the case number and the displacement of the center of the rod in single line. Errors less than 10-6 will be ignored.
Sample Input
3
1000 100 0.0001
150 10 0.00006
10 0 0.001
Sample Output
Case 1: 61.3289915
Case 2: 2.2502024857
Case 3: 0
#include<cstdio>
#include<cmath>
int main()
{
int t,k=0;
double L,n,c,L1;
double r,h;
scanf("%d",&t);
while(t--)
{
scanf("%lf %lf %lf",&L,&n,&c);
double left=0,right=0.5*L,mid;
L1=(1+n*c)*L;
while(right-left>1e-10)
{
mid=(left+right)/2;
r=(4*mid*mid+L*L)/(8*mid);
double sum=2*r*asin(L/(2*r));
if(sum<L1)
left=mid;
else
right=mid;
}
h=mid;
printf("Case %d: %.8lf\n",++k,h);
}
return 0;
}