Dividing

传送门

题面:

Dividing

Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 32517
Accepted Submission(s): 9172

Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value.
Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.

Input

Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, …, n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line ``1 0 1 2 0 0’’. The maximum total number of marbles will be 20000.

The last line of the input file will be ``0 0 0 0 0 0’’; do not process this line.

Output

For each colletcion, output “Collection #k:’’, where k is the number of the test case, and then either ”Can be divided.’’ or “Can’t be divided.’’.

Output a blank line after each test case.

Sample Input

1 0 1 2 0 0
1 0 0 0 1 1
0 0 0 0 0 0

Sample Output

Collection #1:
Can’t be divided.

Collection #2:
Can be divided.

题面描述:

现有面值为1、2、3、4、5、6的硬币若干枚,现在需要知道能不能将这些硬币分成等额的两堆,若输入6个0代表输入结束。单种硬币的数量不会超过20000,若能分割,输出 Can be divided.,若不能输出Can’t be divided.。

题目分析:

部分背包问题:如果硬币总价值是奇数,那么一定不可能被分成等额的两份可以直接输出结果,如果是偶数,则看这一堆硬币能不能凑成所需金额的一半,如果能,那另一半自动凑齐,。

代码:

#include<algorithm>
#include<stdio.h> 
#include<iostream>
#include<string.h> 
#include<queue>
#include<vector>
using namespace std;
int i,j,o=1,a[7],vis[210005],dp[210005];
long long sum;

int main(){
	A:while(cin>>a[1]>>a[2]>>a[3]>>a[4]>>a[5]>>a[6]&&(a[1]||a[2]||a[3]||a[4]||a[5]||a[6])){
		sum=a[1]+2*a[2]+3*a[3]+4*a[4]+5*a[5]+6*a[6];
		if(sum%2){
			printf("Collection #%d:\n",o++);
			cout<<"Can't be divided."<<endl<<endl;
			continue;
		}
		memset(vis,0,sizeof(vis));
		vis[0]=1;//0块钱能够被组成
		sum/=2;
		for(i=1;i<=6;i++){//枚举所有硬币
			memset(dp,0,sizeof(dp));//dp表示价值为i的硬币使用个数
			for(j=i;j<=sum;j++){
				if(vis[j]==0&&vis[j-i]==1&&dp[j-i]+1<=a[i]){//如果当前价值没被拜访过并且该价值减去i块钱是可以被凑成的并且没有超出该种硬币的最大个数
					dp[j]=dp[j-i]+1,vis[j]=1;//更新使用个数并标记该价值被拜访过
				}
				if(vis[sum]==1){
					printf("Collection #%d:\n",o++);
					cout<<"Can be divided."<<endl<<endl;
					goto A;
				}
			}
		}
		printf("Collection #%d:\n",o++);
		cout<<"Can't be divided."<<endl<<endl;
	}
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Yjonben

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值