New Year Book Reading

10 篇文章 0 订阅

传送门

题面:

New Year Book Reading

time limit per test:2 second
memory limit per test:256 megabytes
inputstandard:standard input
outputstandard:standard output

New Year is coming, and Jaehyun decided to read many books during 2015, unlike this year. He has n books numbered by integers from 1 to n. The weight of the i-th (1 ≤ i ≤ n) book is wi.

As Jaehyun’s house is not large enough to have a bookshelf, he keeps the n books by stacking them vertically. When he wants to read a certain book x, he follows the steps described below.

1.He lifts all the books above book x.
2.He pushes book x out of the stack.
3.He puts down the lifted books without changing their order.
4.After reading book x, he puts book x on the top of the stack.

Alt

He decided to read books for m days. In the j-th (1 ≤ j ≤ m) day, he will read the book that is numbered with integer bj (1 ≤ bj ≤ n). To read the book, he has to use the process described in the paragraph above. It is possible that he decides to re-read the same book several times.

After making this plan, he realized that the total weight of books he should lift during m days would be too heavy. So, he decided to change the order of the stacked books before the New Year comes, and minimize the total weight. You may assume that books can be stacked in any possible order. Note that book that he is going to read on certain step isn’t considered as lifted on that step. Can you help him?

Input

The first line contains two space-separated integers n (2 ≤ n ≤ 500) and m (1 ≤ m ≤ 1000) — the number of books, and the number of days for which Jaehyun would read books.

The second line contains n space-separated integers w1, w2, …, wn (1 ≤ wi ≤ 100) — the weight of each book.

The third line contains m space separated integers b1, b2, …, bm (1 ≤ bj ≤ n) — the order of books that he would read. Note that he can read the same book more than once.

Output

Print the minimum total weight of books he should lift, which can be achieved by rearranging the order of stacked books.

Sample Input

3 5
1 2 3
1 3 2 3 1

Sample Output

12

Note

Here’s a picture depicting the example. Each vertical column presents the stacked books.

Alt

题面描述:

有n本书搭在一起,我们有一个看书的顺序。要看第i本书的时候,
我们要把这本书上面所有的书搬起来,把要看的书抽出去,再把搬起来的书按原来顺序放回去,所需要的代价是这本书之上的所有书的重量之和,看完这本书后把这本书放在最上面,问按一定顺序看书最小需要多少代价。这些书初始的摆放顺序可以是任意的。(即我们要让他一开始是最有利的顺序),有可能两本书连续看多次或者隔一段时间看一次。

题目分析:

用结构体存书的重量和位置,先按最优的顺序把书摆好,即要看的书第一次出现的顺序,例如:1 4 3 5 3 1 7,顺序就是:1 4 3 5 7。然后模拟整个过程,取一次书就把它上面所有书的重量加上,并且上面的书位置都减1,把要看的书位置改成1。

代码:

#include<algorithm>
#include<stdio.h> 
#include<stdlib.h>
#include<iostream>
#include<queue>
#include<vector>
#include<string.h>
#include<math.h>
using namespace std;
long long ans=0;
int n,m,b[1005];
struct Book{
	int w,pos;
}book[505];


int main(){
	cin>>n>>m;
	for(int i=1;i<=n;i++) cin>>book[i].w;//第i本书的重量 
	for(int i=1,num=1;i<=m;i++){
		cin>>b[i];//第i天要读的书 
		if(book[b[i]].pos==0) book[b[i]].pos=num++;//先按最优排好书的顺序 
	}
	for(int i=1;i<=m;i++){
		for(int j=1;j<=n;j++){
			if(book[j].pos<book[b[i]].pos&&book[j].pos!=0){
				ans+=book[j].w;
				book[j].pos++;
			}
		}
		book[b[i]].pos=1;
	}
	cout<<ans;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Yjonben

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值