最短路径算法--Til the Cows Come Home

Til the Cows Come Home

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible. 

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it. 

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

* Line 1: Two integers: T and N 

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output

90

Hint

INPUT DETAILS: 

There are five landmarks. 

OUTPUT DETAILS: 

Bessie can get home by following trails 4, 3, 2, and 1.

#include<stdio.h>
#include<string.h>
#define INF 0x3f3f3f3f
int T,N;
//T代表有多少条路,N代表有多少个标记点
int vis[1001],dis[1001],G[1001][1001];
//vis数组用来存放是否已经是最小路径
//dis数组用来表示从源点到i点的最短路径
//G[i][j]数组是表示 从i到j所要花费的时间

int Dijkstra(int u){  //起点u
	/*//初始化vis,让所有点都不在vis数组中 
	memset(vis,0,sizeof(vis));
	//初始化dis,让所有点之间暂无路径 
	memset(dis,INF,sizeof(dis));*/
	for(int i =1;i<=N;i++){
		vis[i] = 0;
		dis[i] = G[u][i];
	}
	
	dis[u]=0;//起点到自己的距离为0 
	vis[u]=1; //vis集合中只有起点 
	
	for(int i = 1;i<N;i++){
		int temp=INF;
		int k=-1;
		for(int j =1;j<=N;j++){//找最小的dis[i],并记录下来 
			if(!vis[j]&&dis[j]<temp){
				temp = dis[j];
				k = j;
			}
		}
		if(k==-1) break;
		//没有找到一条小于INF的边,说明此时集合vis和非vis集合不连通 
		vis[k]=1; //将k纳入集合vis中 
		for(int j = 1;j<=N;j++){ //更新dis数组 
			if(!vis[j]&&dis[j]>dis[k]+G[k][j]){
				dis[j]=dis[k]+G[k][j];
			}
		}
	}
	return dis[1];
}


int main(){
	while(scanf("%d%d",&T,&N)!=EOF){
		memset(G,INF,sizeof(G));
		
		for(int i = 0;i<T;i++){
			int u,v,d;
			scanf("%d%d%d",&u,&v,&d);
			if(G[u][v]>d){
				G[u][v] = G[v][u] = d;
			}
		}
		
		printf("%d\n",Dijkstra(N));
	}
	return 0;
} 
 

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值