POJ - 3186 Treats for the Cows(区间dp)

FJ has purchased N (1 <= N <= 2000) yummy treats for the cows who get money for giving vast amounts of milk. FJ sells one treat per day and wants to maximize the money he receives over a given period time.

he treats are interesting for many reasons:

The treats are numbered 1…N and stored sequentially in single file in a long box that is open at both ends. On any day, FJ can retrieve one treat from either end of his stash of treats.
Like fine wines and delicious cheeses, the treats improve with age and command greater prices.
The treats are not uniform: some are better and have higher intrinsic value. Treat i has value v(i) (1 <= v(i) <= 1000).
Cows pay more for treats that have aged longer: a cow will pay v(i)*a for a treat of age a.
Given the values v(i) of each of the treats lined up in order of the index i in their box, what is the greatest value FJ can receive for them if he orders their sale optimally?

The first treat is sold on day 1 and has age a=1. Each subsequent day increases the age by 1.

Input

Line 1: A single integer, N
Lines 2…N+1: Line i+1 contains the value of treat v(i)

Output
Line 1: The maximum revenue FJ can achieve by selling the treats

Line 1: The maximum revenue FJ can achieve by selling the treats

Sample Input
5
1
3
1
5
2

Sample Output
43

题意:给你一个n个数的序列,每次从队首或队尾取一个数 * 第几次取得它,每次都累加取和,最后求一个最大值。

分析:区间DP。

区间DP:区间dp就是在区间上进行动态规划,求解一段区间上的最优解。主要是通过合并小区间的 最优解进而得出整个大区间上最优解的dp算法。

dp[i][j]表示从i到j的区间的最大和 ,他由dp[i+1][j] 或dp[i][j-1] 转移而来。
状态转移方程: dp[i][j]=max(dp[i+1][j]+a[i](n-(j-i)),dp[i][j-1]+a[j](n-(j-i)));
从n开始往前找最大值,其中(n-(j-i))表示该第几次取数
AC代码:

#include<iostream>
#include<cmath> 
#include<cstring> 
using namespace std;
int dp[2100][2100];     // dp[i][j]表示从i到j的最大和   
int a[2100];			//转移方程  dp[i+1][j]   或   dp[i][j-1] 
int main()
{
	memset(dp,0,sizeof(dp));
	memset(a,0,sizeof(a));
	int n;
	cin>>n;
	for(int i=1;i<=n;i++)
		cin>>a[i];
	for(int i=n;i>=1;i--)
	{
		for(int j=i;j<=n;j++)
		{
			dp[i][j]=max(dp[i+1][j]+a[i]*(n-(j-i)),dp[i][j-1]+a[j]*(n-(j-i)));
		}
	 } 
	 cout<<dp[1][n]<<endl;
	return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

aaHua_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值