HDU - 1930 And Now, a Remainder from Our Sponsor (中国剩余定理)

IBM has decided that all messages sent to and from teams competing in the ACM programming contest should be encoded. They have decided that instead of sending the letters of a message, they will transmit their remainders relative to some secret keys which are four, two-digit integers that are pairwise relatively prime. For example, consider the message “THE CAT IN THE HAT”. The letters of this message are first converted into numeric equivalents, where A=01, B=02, …, Z=26 and a blank=27. Each group of 3 letters is then combined to create a 6 digit number. (If the last group does not contain 3 letters it is padded on the right with blanks and then transformed into a 6 digit number.) For example
THE CAT IN THE HAT → 200805 270301 202709 142720 080527 080120
Each six-digit integer is then encoded by replacing it with the remainders modulo the secret keys as follows: Each remainder should be padded with leading 0’s, if necessary, to make it two digits long. After this, the remainders are concatenated together and then any leading 0’s are removed. For example, if the secret keys are 34, 81, 65, and 43, then the first integer 200805 would have remainders 1, 6, 20 and 38. Following the rules above, these combine to get the encoding 1062038. The entire sample message above would be encoded as
1062038 1043103 1473907 22794503 15135731 16114011
Input
The input consists of multiple test cases. The first line of input consists of a single positive integer n indicating the number of test cases. The next 2n lines of the input consist of the test cases. The first line of each test case contains a positive integer (< 50) giving the number of groups in the encoded message. The second line of each test case consists of the four keys followed by the encoded message.
Each message group is separated with a space.
Output
For each test case write the decoded message. You should not print any trailing blanks.
Sample Input

2
6
34 81 65 43 1062038 1043103 1473907 22794503 15135731 16114011
3
20 31 53 39 5184133 14080210 7090922

Sample Output

THE CAT IN THE HAT
THE END

题意:给定一些密码,每个密码都是7位或者8位,每两位都是之前的数模m[i]的余数,让我们求出原来的数对应的字符串(原来的数一定是六位,每两位构成一个字符,01-26分别代表26个字母,27代表空格)。

思路:题目告诉4个模数两两互质,容易想到crt,然后套个模板就可以了。中间字符串的处理可能会麻烦一些。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<map>
#include<algorithm> 
using namespace std;
typedef long long ll;
map<int,char> mp;
ll m[10],a[10];
int n;
ll exgcd(ll a,ll b,ll &x,ll &y)
{
	if(!b)
	{
		x=1;y=0;return a;
	}
	ll d=exgcd(b,a%b,y,x);
	y-=a/b*x;
	return d;
}
string china(string s,int id)
{
	ll len=s.size(),i=0,k=0,M=1,ans=0;
	for(int i=0;i<4;i++)
		M*=m[i];
	if(len==7)
		a[k++]=s[i++]-'0';
	else
		a[k++]=(s[i++]-'0')*10+s[i++]-'0';
	for(;i<len;i+=2)
		a[k++]=(s[i]-'0')*10+s[i+1]-'0';
	for(int i=0;i<4;i++)
	{
		ll mm=M/m[i];
		ll x,y;
		exgcd(mm,m[i],x,y);
		ans+=mm*a[i]*x;
		ans%=M;
	}
	ans=(ans%M+M)%M;
	string ss("");
	while(ans)
	{
		ss+=mp[ans%100];
		ans/=100;
	}
	i=0;
	if(id==n)
	{
		while(ss[i]==' ')
			i++;
		string tem(ss,i,ss.size()-i);
		ss=tem;
	}
	reverse(ss.begin(),ss.end());
	return ss;
}
int main()
{
	int t;
	cin>>t;
	for(int i=1;i<=26;i++)
		mp[i]='A'+(i-1);
	mp[27]=' ';
	while(t--)
	{
		scanf("%d",&n);
		for(int i=0;i<4;i++)
			scanf("%lld",&m[i]);
		for(int i=1;i<=n;i++)
		{
			string s;
			cin>>s;
			cout<<china(s,i);
		}
		cout<<endl;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值