HDU1930 And Now, a Remainder from Our Sponsor

And Now, a Remainder from Our Sponsor


Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 479 Accepted Submission(s): 195


Problem Description
IBM has decided that all messages sent to and from teams competing in the ACM programming contest should be encoded. They have decided that instead of sending the letters of a message, they will transmit their remainders relative to some secret keys which are four, two-digit integers that are pairwise relatively prime. For example, consider the message "THE CAT IN THE HAT". The letters of this message are first converted into numeric equivalents, where A=01, B=02, ..., Z=26 and a blank=27. Each group of 3 letters is then combined to create a 6 digit number. (If the last group does not contain 3 letters it is padded on the right with blanks and then transformed into a 6 digit number.) For example
THE CAT IN THE HAT → 200805 270301 202709 142720 080527 080120
Each six-digit integer is then encoded by replacing it with the remainders modulo the secret keys as follows: Each remainder should be padded with leading 0’s, if necessary, to make it two digits long. After this, the remainders are concatenated together and then any leading 0’s are removed. For example, if the secret keys are 34, 81, 65, and 43, then the first integer 200805 would have remainders 1, 6, 20 and 38. Following the rules above, these combine to get the encoding 1062038. The entire sample message above would be encoded as
1062038 1043103 1473907 22794503 15135731 16114011


Input
The input consists of multiple test cases. The first line of input consists of a single positive integer n indicating the number of test cases. The next 2n lines of the input consist of the test cases. The first line of each test case contains a positive integer (< 50) giving the number of groups in the encoded message. The second line of each test case consists of the four keys followed by the encoded message.
Each message group is separated with a space.


Output
For each test case write the decoded message. You should not print any trailing blanks.


Sample Input
2
6
34 81 65 43 1062038 1043103 1473907 22794503 15135731 16114011
3
20 31 53 39 5184133 14080210 7090922


Sample Output
THE CAT IN THE HAT
THE END


Source
2007 East Central North America


被这题的输出坑出翔了。。。结尾最后不能有空格,测试数据里结尾有很多个空格的。。

题意:给n串密码,再给4个被取余的数,要求恢复成原来的一串数组(字符)。

分析:中国余数定理。定理里面涉及到了扩展欧几里得。 我的处理方法是从一串数的后面开始取出这些取余剩下的数,然后用中国余数定理处理下求出原来的那个串并记录下来,最后输入字符,也是从后面开始取出数字(这样可以不要管一个数前面的0),但是这样输出的顺序就反了,很简单,用个栈就可以了(先进后出)。

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<vector>
#define LL __int64
using namespace std;
void exgcd(LL a,LL b,LL &d,LL &x,LL &y)
{
    if(!b)
        d=a,x=1,y=0;
    else
    {
        exgcd(b,a%b,d,y,x);
        y-=(a/b)*x;
    }
}
char mark[30]="AABCDEFGHIJKLMNOPQRSTUVWXYZ ";
char s[200];
LL aa[5],bb[5],n,c[55],m1;
LL reminder()
{
    LL m2,r1,r2,c,t,d,x,y;
    m1=aa[0],r1=bb[0];
    for(int i=1;i<4;i++)
    {
        m2=aa[i],r2=bb[i];
        exgcd(m1,m2,d,x,y);
        c=r2-r1;
        t=m2/d;
        x=(c/d*x%t+t)%t;
        r1=m1*x+r1;
        m1=m1*m2/d;
    }
    return r1;
}
int main()
{
    LL temp;
    int i,t,j;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%I64d",&n);
        for(i=0;i<4;i++)
            scanf("%I64d",&aa[i]);
        for(i=0;i<n;i++)
        {
            scanf("%I64d",&temp);
            for(j=3;j>=0;j--)
            {
                bb[j]=temp%100;
                temp/=100;
            }
            int x=reminder();
            c[i]=x;
        }
        int len=0;
        for(i=0;i<n;i++)
        {
            vector<int> q;
            temp=c[i];
            while(temp)
            {
                q.push_back(temp%100);
                temp/=100;
            }
            while(!q.empty())
            {
                temp=q.back();
                q.pop_back();
                s[len++]=mark[temp];
            }
        }
        while(s[len-1]==' ')
            len--;
        for(i=0;i<len;i++)
        printf("%c",s[i]);
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值