PAT甲级1065 A+B and C (64bit)(20分)C语言

1065 A+B and C (64bit)

Given three integers A, B and C in (−2^63 , 2的63), you are supposed to tell whether A+B>C.

Input Specification:
The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:
For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise, where X is the case number (starting from 1). Each line should ends with ‘\n’.

Sample Input:

3
1 2 3
2 3 4

9223372036854775807 -9223372036854775808 0

Sample Output:
Case #1: false
Case #2: true
Case #3: false

思路:通过查阅资料发现C语言中变量long long
的范围正好是他给的数字的范围,但是由于是A+B>C,那么在相加的过程中,一不小心就溢出了,那么我们为了考虑这种情况,我们在两个数(A,B)都是为正的,而且C也为正,那么我们选择把B挪过去,我们来判断A是否大于C-B,如果在三个数(A,B,C)均是负数的情况下,我们也是选择把B挪过去,这样也是完美的躲开了数据溢出的问题。

代码如下(编译器是dev,语言是C语言):

#include<stdio.h>
#include<math.h>
long long A,B,C;
int N,i;
int main(){
    scanf("%d",&N);
    for(i = 1;i<=N;i++){
        scanf("%lld %lld %lld",&A,&B,&C);
        if((A>=0)&&(B>=0)){//同为不负
            if(C<0){
                printf("Case #%d: true",i);
            }else{
                if(A>(C-B)){
                    printf("Case #%d: true",i);
                }else{
                    printf("Case #%d: false",i);
                }
            }
        }else if((A<0)&&(B<0)){//同为负
            if(C>=0){
                printf("Case #%d: false",i);
            }else{
                if(A>(C-B)){
                    printf("Case #%d: true",i);
                }else{
                    printf("Case #%d: false",i);
                }
            }
        }else{
            if((A+B)>C){
                printf("Case #%d: true",i);
            }else{
                printf("Case #%d: false",i);
            }
        }
        if(i != N){
            printf("\n");
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值