ACM新手训练题(HDU - 2101)

A + B Problem Too HDU - 2101
原题目:
This problem is also a A + B problem,but it has a little difference,you should determine does (a+b) could be divided with 86.For example ,if (A+B)=98,you should output no for result.

Input
Each line will contain two integers A and B. Process to end of file.

Output
For each case, if(A+B)%86=0,output yes in one line,else output no in one line.

    Sample Input
    1 1
    8600 8600

    Sample Output
    no
    yes

题目简述:
输入两个数并判断两个数能否被86整除。
题目分析:
需要考虑一个特殊数据,两个数为零的时候。
AC代码:

#include<iostream>
using namespace std;
int main()
{
 int a, b;
 while (cin >> a >> b)
 {
        if (a == 0 && b == 0)
      {
        cout << "no" << endl;
      }
         else if ((a + b) % 86 == 0)
      {
            cout << "yes" << endl;
      }
          else
      {
              cout << "no" << endl;
      }
 }
 return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值