ACM训练题(HDU - 1013)

HDU - 1013
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

Input
The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.

Output
For each integer in the input, output its digital root on a separate line of the output.

Sample Input
24
39
0

Sample Output
6
3
题目简述:
给出一个数,这个数可能很大很大,我们需要求这个数的数根。即这个数的各位相加得出来的数,且这个数必须为个位数。例如:24的数根是2+4=6,数根就是6;39的数根是
3+9=12,但12不是个位数,所以还要再加一次,即1+2=3,所以39的数根是3。
题目分析:
方法一:
在不知道求数根公式的情况下,我们的代码就要复杂一些了。首先,这个数可能非常非常大,所以我们不能使用整型,我们应该使用一个字符数组来接收这个输入的数,再将字符转化为整数,相加。相加过后我们还要判断这个数是否大于10,如果不大于10,直接输出即可,如果大于等于10,我们还要再加一次。在一个数非常非常大的时候,如果在使字符全部转化为整型后再来判断并且重复相加,这个时候我们的程序就会超时,因为循环太多了。我们可以边相加边判断,是否大于等于10,这样可以保证此时的数绝不会超过100。AC代码在下面。
方法二:
还有一个办法就是在知道了求数根的公式后,一切都简单了。
公式为:n的数根为:(n-1)%9+1;AC代码也在下面。
方法一AC代码:

#include<iostream>
#include<cstring>
using namespace std;
int main()
{
	char s[10000];
	while (cin >> s)
	{
		long  i = 0, n = 0, t = 0,m=0;
		if (s[0]=='0')
			break;
		for (i = 0; i < strlen(s); i++)
		{
			n = n + s[i] - '0';
			while (n >= 10)
			{
				t = n % 10;
				m = n / 10;
				n = t + m;
			}
		}
		cout << n << endl;
	}
	return 0;
}

方法二AC代码:

#include<iostream>
#include<cstring>
using namespace std;
int main()
{
 char s[10000];
 while (cin >> s)
 {
  long  i = 0, n = 0, t = 0,m=0;
  if (s[0]=='0')
   break;
  for (i = 0; i < strlen(s); i++)
   n = n + s[i] - '0';
  cout << (n - 1) % 9 + 1 << endl;
 }
 return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值