深搜(联通块)——Counting sheep

Counting Sheep

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)

Total Submission(s) : 38   Accepted Submission(s) : 27

Font: Times New Roman | Verdana | Georgia

Font Size: ← →

Problem Description

A while ago I had trouble sleeping. I used to lie awake, staring at the ceiling, for hours and hours. Then one day my grandmother suggested I tried counting sheep after I'd gone to bed. As always when my grandmother suggests things, I decided to try it out.
 The only problem was, there were no sheep around to be counted when I went to bed.

Creative as I am, that wasn't going to stop me. I sat down and wrote a computer program that made a grid of characters, where # represents a sheep, while . is grass (or whatever you like, just not sheep). To make the counting a little more interesting, I also
 decided I wanted to count flocks of sheep instead of single sheep. Two sheep are in the same flock if they share a common side (up, down, right or left). Also, if sheep A is in the same flock as sheep B, and sheep B is in the same flock as sheep C, then sheeps
 A and C are in the same flock.
Now, I've got a new problem. Though counting these sheep actually helps me fall asleep, I find that it is extremely boring. To solve this, I've decided I need another computer program that does the counting for me. Then I'll be able to just start both these
 programs before I go to bed, and I'll sleep tight until the morning without any disturbances. I need you to write this program for me.

Input

The first line of input contains a single number T, the number of test cases to follow.
Each test case begins with a line containing two numbers, H and W, the height and width of the sheep grid. Then follows H lines, each containing W characters (either # or .), describing that part of the grid.

Output

For each test case, output a line containing a single number, the amount of sheep flock son that grid according to the rules stated in the problem description.
Notes and Constraints
0 < T <= 100
0 < H,W <= 100

Sample Input

2
4 4
#.#.
.#.#
#.##
.#.#
3 5
###.#
..#..
#.###


Sample Output

6
3


Source

IDI Open 2009
 

题意:输入h*w的草地,其中#代表羊,相邻上下左右为联通,求草地中联通块的个数。

用dfs,每找到一只羊就把它标记,这里因为要计算联通块总数,所以标记直接为联通块的标号,然后开始搜索这只羊的上下左右四个方向,找到下一只羊就标记,再找它的下一只。

 

代码如下:

#include<bits/stdc++.h>
using namespace std;
char a[105][105];
int idx[105][105];
int h, w;
void dfs(int r, int c, int index)
{
	if (r < 0 || r >= h || c < 0 || c >= w || idx[r][c] || a[r][c] != '#')
		return;
	idx[r][c] = index;
	dfs(r - 1, c, index);
	dfs(r, c - 1, index);
	dfs(r + 1, c, index);
	dfs(r, c + 1, index);
}
int main()
{
	int t;
	cin >> t;
	while (t--)
	{
		cin >> h >> w;
		for (int i = 0;i < h;i++)
			for (int j = 0;j < w;j++)
				cin >> a[i][j];
		int cnt = 0;
		memset(idx, 0, sizeof(idx));
		for (int i = 0;i < h;i++)
			for (int j = 0;j < w;j++)
				if (!idx[i][j] && a[i][j] == '#')
					dfs(i, j, ++cnt);
		cout << cnt << endl;
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值