问题
People often have a preference among synonyms of the same word. For example, some may prefer “the police”, while others may prefer “the cops”. Analyzing such patterns can help to narrow down a speaker’s identity, which is useful when validating, for example, whether it’s still the same person behind an online avatar.
Now given a paragraph of text sampled from someone’s speech, can you find the person’s most commonly used word?
Input Specification:
Each input file contains one test case. For each case, there is one line of text no more than 1048576 characters in length, terminated by a carriage return \n. The input contains at least one alphanumerical character, i.e., one character from the set [0-9 A-Z a-z].
Output Specification:
For each test case, print in one line the most commonly occurring word in the input text, followed by a space and the number of times it has occurred in the input. If there are more than one such words, print the lexicographically smallest one. The word should be printed in all lower case. Here a “word” is defined as a continuous sequence of alphanumerical characters separated by non-alphanumerical characters or the line beginning/end.
Note that words are case insensitive.
Sample Input:
Can1: “Can a can can a can? It can!”
Sample Output:
can 5
解决方法
分析:map的应用
#include<iostream>
#include<map>
#include<string>
using namespace std;
int main()
{
int maxtime=0;
string s,t,maxstring;
getline(cin, s);
map<string, int>m;
for (int i = 0; i < s.size(); i++)
{
if (isalnum(s[i]))
{
t +=tolower(s[i]);
}
if (!isalnum(s[i]) || i == s.length() - 1)
{
if (t.length() != 0) m[t]++;
t = "";
}
}
for (auto it = m.begin(); it != m.end(); it++)
{
if (it->second > maxtime)
{
maxtime = it->second;
maxstring = it->first;
}
}
cout << maxstring << " " << maxtime;
return 0;
}
后记
这道题不难,需要注意的只有两个点:一个是如何分隔字符串,另外一个是最后一个测试点的通过:如果i已经到了最后⼀位,不管当前位是不是字⺟数字,都得将当前这个t放到map⾥⾯(只要t⻓度不为0)