HDU 1045 Fire Net (搜索)

31 篇文章 0 订阅

Problem Description

Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall.

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening.

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets.

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through.

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways.



Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration.

Input

The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file.

Output

For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.

Sample Input

4
.X..
....
XX..
....
2
XX
.X
3
.X.
X.X
.X.
3
...
.XX
.XX
4
....
....
....
....
0

Sample Output

5
1
5
2
4

题目意思

图中方块为墙,圆为堡垒,两个堡垒不能处于同行或者同列,但是如果有墙阻挡即可

找出每组能防止最多的堡垒数目,用深搜,记录能放置的最大个数

#include<iostream>
#include<stdio.h>
using namespace std;
char map[10][10];
int ans = 0, n;
int check(int x, int y){             //上下左右四个方向检查是否有冲突的堡垒
	if (map[x][y] != '.')return 0;  //  如果有墙则表明该方向可以,进行下一方向的检查
	if (x > 0)                      // X 为墙, A为放置过的堡垒
		for (int i = x - 1; i >= 1; i--)
		{
			if (map[i][y] == 'A')
				return 0;
			if (map[i][y] == 'X') break;
		}
	if (x < n)
		for (int i = x + 1; i <= n; i++)
		{
			if (map[i][y] == 'A')
				return 0;
			if (map[i][y] == 'X') break;
		}
	if (y > 0)
		for (int j = y - 1; j >= 1; j--)
		{
			if (map[x][j] == 'A')
				return 0;
			if (map[x][j] == 'X') break;
		}
	if (y < n)
		for (int i = y + 1; i <= n; i++)
		{
			if (map[x][i] == 'A')
				return 0;
			if (map[x][i] == 'X') break;
		}
	return 1;
}
void dfs(int d){
	if (d > ans)ans = d;
	for (int i = 1; i <= n; i++)
		for (int j = 1; j <= n; j++)
		{
			if (check(i, j))
			{
				map[i][j] = 'A';         //将该处标记为放置过
				dfs(d + 1);             //继续放置下一个堡垒
				map[i][j] = '.';
			}
		}
}
int main(){
	while (cin >> n&&n){
		ans = 0;
		for (int i = 1; i <= n; i++)
			scanf("%s", map[i] + 1);
		dfs(0);
		cout << ans << endl;
	}
        return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值