The number of divisors(约数) about Humble Numbers hdu 1492

Problem Description

A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers. 

Now given a humble number, please write a program to calculate the number of divisors about this humble number.For examle, 4 is a humble,and it have 3 divisors(1,2,4);12 have 6 divisors.

Input

The input consists of multiple test cases. Each test case consists of one humble number n,and n is in the range of 64-bits signed integer. Input is terminated by a value of zero for n.

Output

For each test case, output its divisor number, one line per case.

Sample Input

4 12 0

Sample Output

3 6

 

题意:给你一个数n,这个数n的素因子如果存在就只存在2,3,5,7的素因子,求这个数的约数的个数

思路:唯一分解定理,用2^e1 * 3 ^ e2  * 5 ^ e3 * 7 ^ e4表示n,则约数的个数为(e1 + 1) * (e2 + 1) * (e3 + 1) * (e4 + 1)

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<vector>
#include <map>
using namespace std;
const int MAX = 1e6 + 50;
typedef long long LL;

LL a[] = {2, 3, 5, 7};
LL num[10];
int main(){
	LL n;
	while(~scanf("%I64d", &n)){
		LL ans = 1;
		if(n == 0){
			break;
		}
		for(LL i = 0; i < 4; i++){
			num[i] = 0;
			while(n % a[i] == 0){
				num[i]++;
				n /= a[i];
			}
			ans *= (num[i] + 1);
		}

		printf("%I64d\n", ans);
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值